Bug 601234 - tuna: no way to change individual thread attributes of thread group in GUI
Summary: tuna: no way to change individual thread attributes of thread group in GUI
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
(Show other bugs)
Version: 1.2
Hardware: All Linux
low
low
Target Milestone: 2.3
: 2.3
Assignee: Arnaldo Carvalho de Melo
QA Contact: David Sommerseth
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 14:17 UTC by Clark Williams
Modified: 2016-05-22 23:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Ability to change individual thread policy attributes rather than at the thread-group level Reason: Need to be able to modify individual thread to change priority or affinity. Result (if any): Feature added
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 18:48:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0563 normal SHIPPED_LIVE Red Hat Enterprise MRG Realtime 2.3 Update 2013-03-06 23:37:24 UTC

Description Clark Williams 2010-06-07 14:17:37 UTC
Description of problem:
The tuna GUI will now allow changing individual thread scheduling policy inside a thread group (only allows process group change)

Version-Release number of selected component (if applicable):
tuna-0.9.4

How reproducible:
always

Steps to Reproduce:
1. run 'cyclictest -t'
2. start tuna gui
3. expand cyclictest threadgroup
4. right mouse on desired thread to change
5. select 'set process attributes'
  
Actual results:
No pop-up dialog to change thread attributes

Expected results:
dialog

Comment 2 David Sommerseth 2013-02-20 18:14:13 UTC
Verified on tuna-0.10.4-3.el6rt.noarch.  Followed the reproducer, which now allowed threads to be modified independently.

Comment 4 errata-xmlrpc 2013-03-06 18:48:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0563.html


Note You need to log in before you can comment on or make changes to this bug.