Bug 601235 - RFE: keep machine reserved (i.e. owned by the user) after job is done
Summary: RFE: keep machine reserved (i.e. owned by the user) after job is done
Status: CLOSED DUPLICATE of bug 639938
Alias: None
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
low
medium vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 14:17 UTC by Marian Csontos
Modified: 2014-08-12 04:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 12:20:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marian Csontos 2010-06-07 14:17:50 UTC
Add "keep" option to system, recipe and/or recipeset, so the machine does not get recycled when the job is done, but current user is kept, until it is returned manually.

== Rationale ==

- sometimes a problem occurs during test execution, which needs developer attention,
- and as this is not know in advance usually user cannot add /distribution/reservesys to recipe,
- and even with reservesys in the recipe, it would not work when recipe gets aborted.

Comment 1 Bill Peck 2010-07-22 20:49:12 UTC
I would consider pushing the watchdog time out a predetermined amount of time but I won't allow it be "forever".

Comment 2 Marian Csontos 2010-10-04 12:20:30 UTC
Closing this as obsolete by Bug 639938.

*** This bug has been marked as a duplicate of bug 639938 ***


Note You need to log in before you can comment on or make changes to this bug.