Bug 60124 - Q-logic Driver problem
Q-logic Driver problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 12:20 EST by harry.heinisch
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 03:17:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2002-02-20 12:20:26 EST
Description of Problem:

Placing a load on a system with a Q-logic controller causes the system to hang.
Examination of the Kernel Log Biffer indicates there's an "invalid translation"
recorded from the Q-logic buffer...


Version-Release number of selected component (if applicable):


How Reproducible:
 Always/consistent

Steps to Reproduce:
1. Running our disk test suite always causes this to occur.
2. 
3. 

Actual Results:  system hang


Expected Results: no system hang 


Additional Information:  

  Thomas.Sharbaugh@compaq.com
Comment 1 Phil Copeland 2002-02-20 14:03:43 EST
which qlogic ontroller?
1020?
Comment 2 harry.heinisch 2002-02-21 08:49:56 EST
This module has the 1040B chio on board...
Comment 3 Beth Uptagrafft 2002-02-26 13:41:11 EST
What system does this occur on?
Comment 4 harry.heinisch 2002-02-27 09:48:01 EST
ES40 w/ 4gb mem 

DS20e w/2gb mem

This bug has been reproduced on the rc1 bits.

Thomas.Sharbaugh@compaq.com
Comment 5 Alexandre Petit-Bianco 2002-03-11 14:51:36 EST
I've been running cerberus on an ES40 with 4GB of ram an a revision 5 Q-Logic 
controller (identified as featuring the 1040B chio on board.)

I couldn't reproduce the problem after several days of running cerberus. Is 
your disk test suite available? Could it be made available to us?
Comment 6 Phil Copeland 2002-03-12 14:12:50 EST
Hummmm
Ok having done a 'number 5 disassemble' on the 4100 and extracted the qlogic
card and disk array from it, we've found that alpha is damned lucky that it
works at all, as it will fail miserably on an intel box.

Intel is not my strong suit so I'm going to let Elliot and Doug thrash out whats
going on. Elliot does have a patch that seems to work but slows down the
performance somewhat which /may/ be masking the real problem.

Phil
=--=
Comment 7 harry.heinisch 2002-03-14 11:29:21 EST
Yes the test suite is available.  It's simply called "dt" or disk test.
You can find it at emperor.mro.cpqcorp.net/pub/linux/tools/dt/alpha-dt.tar.gz

If you drop me a mail message, (thomas.sharbaugh@compaq.com), I'll tell you 
how to set it up and how I run it.

     tom
Comment 8 Phil Copeland 2002-04-03 03:17:52 EST
Ok,.. made all the fun changes to make the feral qlogic isp driver the default
I've made no tests on performance, so... no promises 8)
The qlogicisp.o module is no more (though I can revert that but is seems daft to
have the two modules around competeting for the same resource)

I do NOT know what it's >2Gb ability is like. Someone needs to test that. I'll
make a kernel to test with available on request

Phil
=--=
Comment 9 Phil Copeland 2002-04-03 18:03:08 EST
Humm Doug Ledford just came back with a fixed up qlogicisp.o module...
Ummm,... well I can make that available but not make it a default. IE if people
wanna play they can use the qlogicisp.o module AFTER installation (same sort of
scenario as the tulip.o/de4x5.o modules just with isp_mod.o/qlogicisp.o

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.