Bug 601261 - yum-plugin-post-transaction-actions triggers actions at the end of the yum transaction
Summary: yum-plugin-post-transaction-actions triggers actions at the end of the yum tr...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: 13
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 15:21 UTC by Patrick Pichon
Modified: 2014-01-21 23:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 15:35:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Pichon 2010-06-07 15:21:31 UTC
Description of problem:
The yum-plugin-post-transaction-actions plugging allows the user to run arbitrary actions immediately following a transaction when specified ackages are changed.

As the plugin give information on the package and the state (remove, update, install) it would be better to have the action triggers after the package action and not at the end of the YUM transaction.

Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
1. install the package yum-plugin-post-transaction-actions
2. configure /etc/yum/post-actions/sample.action in order to trigger a command
3. do a yum update. 
  
Actual results:
The command configured in the sample.action will be trigger at the end of the yum update when all packages are updated/removed or installed.

Expected results:
The command is trigger after EACH package update/remove or installation.

Additional info:

Comment 1 seth vidal 2010-06-07 15:35:38 UTC
posttransaction actions happen after the transaction is over entirely.

It was never intended to work otherwise.


Note You need to log in before you can comment on or make changes to this bug.