Bug 60128 - nv driver causes garbled display
nv driver causes garbled display
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 12:59 EST by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 04:52:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2002-02-20 12:59:23 EST
01:00.0 VGA compatible controller: nVidia Corporation NV11 GL (rev b2) (prog-if
00 [VGA])
        Subsystem: Siemens Nixdorf AG: Unknown device 0082
        Flags: 66Mhz, medium devsel, IRQ 5
        Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

On this hardware, the nv driver doesn't work at all (garbled display).

(e.g. Fujitsu/Siemens Celsius Mobile H notebook).
Comment 1 Mike A. Harris 2002-02-22 04:49:47 EST
Please attach logs + configs.  Might be fixed in 4.2.0.  If not though,
I'll need to change it's default driver to something else.
Comment 2 Mike A. Harris 2002-02-22 04:50:18 EST
oh, try disabling accel and/or swcursor first.
Comment 3 Bernhard Rosenkraenzer 2002-02-25 04:24:21 EST
Still broken with 4.2.0 and noaccel
Comment 4 Bernhard Rosenkraenzer 2002-02-25 04:35:24 EST
 The log doesn't have anything unusual (this is 4.2.0-6.36) - from the log, it looks like 
everything is ok, just the display isn't.
Comment 5 Bernhard Rosenkraenzer 2002-02-25 04:41:42 EST
The graphics chipset seems to be paperweight (like everything NVidia ;) ). 
The vga driver does the same mess unless it's in 320x200xu8. 
 
The only way to get this POS card to work appears to be using fbdev. 
Comment 6 Bernhard Rosenkraenzer 2002-02-25 04:52:43 EST
Confirmed to work with fbdev and nothing else. 
 
Btw: I won't have access to this piece of hardware anymore after today (it's a test box 
from Siemens, and being returned this evening).
Comment 7 Mike A. Harris 2002-03-04 21:26:39 EST
Dont have hardware to test with.

Note You need to log in before you can comment on or make changes to this bug.