Bug 601284 - [as4] Unable to resubmit a failed WAR child create request
Summary: [as4] Unable to resubmit a failed WAR child create request
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
(Show other bugs)
Version: 3.0.0
Hardware: All Linux
low
low vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 15:49 UTC by Lukas Krejci
Modified: 2010-09-24 12:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-24 12:55:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Krejci 2010-06-07 15:49:20 UTC
Description of problem:

trying the $SUBJECT results in the following error being displayed in the UI.

Failed to send create resource request to agent. Cause: javax.ejb.EJBException:javax.persistence.PersistenceException: org.hibernate.PersistentObjectException: detached entity passed to persist: org.rhq.core.domain.configuration.Configuration -> javax.persistence.PersistenceException:org.hibernate.PersistentObjectException: detached entity passed to persist: org.rhq.core.domain.configuration.Configuration -> org.hibernate.PersistentObjectException:detached entity passed to persist: org.rhq.core.domain.configuration.Configuration 
Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. JBoss AS Inventory page, create new child drop down, select "Web Application (WAR)"
2. Click "Upload File", and upload an intentionally corrupted war file (so that the deployment fails)
3. Finish the deployment
4. Back on the inventory page, click on "Resubmit" link in the "Create Child Resource Requests" table
5. This time upload a "deployable" war file.
6. Notice the error message once you finish the deployment.
  
Actual results:
A create child resource request can't be resubmitted

Expected results:
A request should be resubmitted.

Additional info:

Since one has to fill in and upload all the data again in the resubmit workflow anyway, this isn't much different from just making a new create request.

Comment 1 Corey Welton 2010-09-24 12:55:51 UTC
closing per gwt effort


Note You need to log in before you can comment on or make changes to this bug.