Bug 60131 - Apropos broken; passes bad arguments to grep.
Summary: Apropos broken; passes bad arguments to grep.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-20 18:25 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 18:25:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-02-20 18:25:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
apropos is broken in man-1.5j-2 (a rawhide package, but I believe it was also
broken in standard 7.2).  The problem is setting aproposgrepopt2='a' at the top
of the script--this grepopt needs to be empty because it is pasted before the
token we are searching for (eg, 'apropos man' will grep for 'aman' with this
option set as is.  the whatisgrepopt2 is fine--the '^' option gets pasted before
the token and we grep for '^man' which does what we want.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. apropos ncftp
2. 
3.
	

Actual Results:  You get no results (unless you have a program called 'ancftp'
on your machine).

Expected Results:  Should have returned a list of all man pages with 'ncftp' in
them.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-02-25 13:14:04 UTC
 Thanks, fixed in 1.5j-3


Note You need to log in before you can comment on or make changes to this bug.