Bug 601339 - kde should start gnome-keyring
kde should start gnome-keyring
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 13:58 EDT by ritz
Modified: 2011-10-17 04:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 749994 (view as bug list)
Environment:
Last Closed: 2011-10-17 04:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (190 bytes, patch)
2010-06-07 14:02 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2010-06-07 13:58:04 EDT
Description of problem:
When running KDE, NetworkManager does not save wireless keys.

steps to re-produce:
  1. Connect to wireless network
  2. Enter wireless key when prompted (via NetworkManager)
  3. Access internet
  4. Rebootthe system and re-login
  5. NetworkManager auto-connects to wireless networkand prompts again for wireless key

Actual result:
"$ ps aux|grep keyring" does not list keyring process. 

Expected result
gnome-keyring should run.

Additional Information:
  gnome-keyring does not start with kde. This would need to be started via /etc/kde/env, as gnome-keyring requires GNOME_KEYRING_SOCKET variable to set. This is required, as gnome-keyring 0.6 does not use dbus.
Comment 1 ritz 2010-06-07 14:02:41 EDT
Created attachment 421905 [details]
patch
Comment 2 RHEL Product and Program Management 2011-05-31 10:42:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.