Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601367 - lvm based guest images and most likely guest OS lvm filesystem requests not being processed properly by beaker
lvm based guest images and most likely guest OS lvm filesystem requests not b...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
x86_64 Linux
high Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
: Regression, TestBlocker
Depends On:
Blocks: 593663 593365
  Show dependency treegraph
 
Reported: 2010-06-07 15:24 EDT by Barry Marson
Modified: 2011-06-13 14:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 13:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
legacy rhts xml (2.80 KB, application/octet-stream)
2010-06-07 15:24 EDT, Barry Marson
no flags Details

  None (edit)
Description Barry Marson 2010-06-07 15:24:35 EDT
Created attachment 421923 [details]
legacy rhts xml

Description of problem:

beaker job https://beaker.engineering.redhat.com/jobs/1908 was an attempt to queue fully automated virtualization jobs.  The job failed because the guestrecipe definition defining guest image storage size/type was not processed properly and not created in the host recipe kickstart.  This is first noticed in /distribution/virt/install when it attempts to use the missing lvm blk device.

Additionally, it has been brought to my attention that if the guest OS needs to specify file systems to be created that are based on lvm, that they probably arent being handled either.  This example does not require such an item, but when we start testing RHEL6 guests, it will be a requirement.

Without this functionality, automated ISV tests in a virtualized guest cannot be tested.  Manual testing is not practical.

Version-Release number of selected component (if applicable):
 Version - 0.5.41 ??

How reproducible:
see job referenced above plus the legacy rhts xml.

Steps to Reproduce:
1. queue the xml attached with the --convert option since it's legacy rhts
2.
3.
  
Actual results:


Expected results:


Additional info:

I will attache the legacy rhts xml that beaker converts...
Comment 1 David Kovalsky 2010-06-14 13:08:44 EDT
Regression against RHTS, can't work in Beaker -> suggesting to be a blocker.
Comment 2 David Kovalsky 2010-06-14 13:12:38 EDT
Context:

This effects all ISV in virt testing. Started doing in 5.5 to test ISV apps in guests. Need this to support RHEL6.
Comment 3 Bill Peck 2010-07-26 15:37:36 EDT
I have just committed this to git.  I'll be testing this Tonight and Tomorrow.

One thing needed still is an option to bkr job-submit to autogenerate the partition tags based on the guest kickstarts disk requirements.

Note You need to log in before you can comment on or make changes to this bug.