Bug 60138 - adsl-stop don't kill a still running adsl-connect
Summary: adsl-stop don't kill a still running adsl-connect
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-20 19:43 UTC by Peter Bieringer
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 19:43:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bieringer 2002-02-20 19:43:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17-0.13 i686)

Description of problem:
If "adsl-connect" can't bring up the pppd because of a configuration problem,
e.g. "ifdown ppp0" don't kill "adsl-connect" itself, therefore not really
shutdown the ADSL connection program

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Use a invalid options for pppd, e.g. 
PPPD_EXTRA="active-filter '(outbound and not icmp)'"

which is another bug, I'll report them after this one


Actual Results:  


Additional info:

Fix below helps, but I don't know whether it's correct:

--- adsl-stop.orig      Sun Feb 17 16:05:34 2002
+++ adsl-stop   Sun Feb 17 16:05:51 2002
@@ -53,7 +53,7 @@
     PID=`cat $PIDFILE`

     # Check if still running
-    kill -0 $PID > /dev/null 2>&1
+    kill $PID > /dev/null 2>&1
     if [ $? != 0 ] ; then
        echo "$ME: The adsl-connect script (PID $PID) appears to have
died" >& 2
     fi

Comment 1 Ngo Than 2002-02-23 15:43:55 UTC
It's fixed in rp-pppoe-3.3-6.


Note You need to log in before you can comment on or make changes to this bug.