Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601388 - Performance degradation on newer kernel 2.6.18-194
Performance degradation on newer kernel 2.6.18-194
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 16:37 EDT by infratirio
Modified: 2012-01-18 12:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 12:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 37533 None None None Never

  None (edit)
Description infratirio 2010-06-07 16:37:08 EDT
Description of problem:

     I'm using RHEL 5 on a cluster environment for seismic simulation. In this enviroment we are using 32 HP's DL160 G6 powered with two Intel X5570 CPU using the new nehalem microarchitecture. In the default DL160 configuration, the OS sees 16 processors instead of 8 because of the hyperthreading

We saw a performance degradation when we moved from RHEL 5.4 to RHEL 5.5. Our simulations took 10% more time to run on the newer RHEL 5.5 using the same simulation software and dataset.

Version-Release number of selected component (if applicable):

kernel kernel-2.6.18-194.el5 and kernel-2.6.18-194.3.1.el5

How reproducible:

    Just start a simulation job with 8 parallel process and wait for simulation timing results gave after the simulation job finished. In RHEL 5.4's kernel version kernel-2.6.18-164.el5 we can see a steady result of ~856 secods with less then 1 percent of standard deviation. This RHEL 5.5's kernel version kernel-2.6.18-194.el5 or even with the newest errata kernel-2.6.18-194.3.1.el5 we can experiment a 10% increase in the processing time with more than 30% of standard deviation.

Actual results:

This are the times we can get with kernel-2.6.18-194.el5 and kernel-2.6.18-194.3.1.el5

 Final cpu     987.82 elapsed     990.14
 Final cpu     903.95 elapsed     906.42
 Final cpu     999.24 elapsed    1001.67
 Final cpu     898.51 elapsed     900.83
 Final cpu     927.19 elapsed     929.51

Expected results:

This is the expected time and what we can get from kernel-2.6.18-164.el5

 Final cpu     857.43 elapsed     859.96
 Final cpu     856.02 elapsed     859.00
 Final cpu     855.96 elapsed     858.78
 Final cpu     856.09 elapsed     858.88
 Final cpu     855.83 elapsed     858.81


Additional info:

We did an aditional test that involved installing RHEL 5.5 and downgrading just the kernel to kernel-2.6.18-164.el5 and the results are the same as running a full install RHEL 5.4, which means the expected result time of ~856 seconds.
Comment 2 Chris Williams 2012-01-18 12:19:59 EST
It has been some time since this BZ was updated. Both customer issues have closed due to lack of updates. Closing NOTABUG.
If this is still an issue, please feel free to open a case with Red Hat Support via the Customer Portal.

Note You need to log in before you can comment on or make changes to this bug.