Bug 60139 - ADSL/PPP setup don't allow special pppd options in single quotes
Summary: ADSL/PPP setup don't allow special pppd options in single quotes
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-20 19:48 UTC by Peter Bieringer
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-10 01:40:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bieringer 2002-02-20 19:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17-0.13 i686)

Description of problem:
I've recompiled pppd to use the FILTER option. Working great, but I cannot
specify extended filter configuration, because they have to be between single
quotes which isn't supported by the scripts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Working example:
PPPD_EXTRA="active-filter outbound"

Not working example:
PPPD_EXTRA="active-filter 'outbound and not icmp[0] == 3 and not tcp[13] & 4 !=
0'"



Actual Results:  Error message in log is
Feb 17 16:58:14 gate pppd[28416]: error in active-filter expression:
illegal char '''


Additional info:

I've debugged around in the script "adsl-connect", but didn't succeed.

The problem is somewhere around:

$SETSID $PPPD $PPP_STD_OPTIONS $DEMAND &

Putting the $PPP_STD_OPTIONS between " didn't help too, because now
pppd treats this all as one option.

Comment 1 Ngo Than 2002-02-23 17:41:55 UTC
It's a bug in ppp.

Comment 2 Peter Bieringer 2003-12-10 01:40:42 UTC
Thanks to hints in bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71247

this issue can be solved easily:
1) activate filtering in pppd (see also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=71247)
2) create a file  /etc/ppp/options.adsl containing e.g.
active-filter 'outbound and !(udp dst port ntp || udp dst port 3740)'
3) specify usage of this file for additional options in e.g.
/etc/sysconfig/network-scripts/ifcfg-ppp0 by
PPPD_EXTRA="file /etc/ppp/options.adsl"

Voila.


Note You need to log in before you can comment on or make changes to this bug.