Bug 60141 - Source package won't build as non-root user
Summary: Source package won't build as non-root user
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dialog   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-20 20:24 UTC by Ed Avis
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 20:24:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Avis 2002-02-20 20:24:19 UTC
% rpm --rebuild dialog-0.6-16.src.rpm 
[snip]
make[1]: Entering directory `/usr/src/redhat/BUILD/dialog-0.6/src'
install -m 755 -o root -g root dialog /var/tmp/dialog-root/usr/bin
install: /var/tmp/dialog-root/usr/bin/dialog: Operation not permitted
make[1]: *** [install] Error 1

The 'make install' process is trying to install files owned by root.  This means
you have to be root to rebuild the source package, which is a Bad Thing.

Would be better to specify file ownership in the %files part of the spec file
rather than by chmodding as part of 'make install'.

Comment 1 Harald Hoyer 2002-02-21 09:56:24 UTC
works for me with the current dialog-0.9a-6.src.rpm. You may consider to take a newer version?



Note You need to log in before you can comment on or make changes to this bug.