This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 60147 - /dev/ida nodes not getting created in initrd image
/dev/ida nodes not getting created in initrd image
Status: CLOSED DUPLICATE of bug 62206
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-02-20 17:51 EST by Issue Tracker
Modified: 2007-03-26 23:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 12:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2002-02-20 17:51:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
system will fail to reboot (unable to mount root) if you install to cpqarray
controller (cciss controllers may have the same issue).  Because /dev/ida nodes
not getting created in initrd image

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install
2.Reboot
3.
	

Actual Results:  Standard "init not found" message

Expected Results:  Machine should boot.

Additional info:

Cut-n-paste from originating issue...


OS: 8.0 Beta1 Hampton system will fail to reboot (unable to mount root) if you
install to cpqarray controller (cciss controllers may have the same issue). 
Because /dev/ida nodes not getting created in initrd image. They appear to be
ignoring the root= passed in from grub or lilo and this is not working.  Only
way I could get the system to boot is to create /dev/ida nodes in initrd and
then hard code /dev/ida/c0d0p3 on the mount command in initrd.
Comment 1 Jeremy Katz 2002-02-22 18:42:19 EST
Hrmm... this code hasn't changed in any way that I can think of.  I'll have to
track down hardware now that we've moved since I don't have any and see if it
still happens with the new Hampton
Comment 2 Jeremy Katz 2002-03-07 18:13:45 EST
Does this still happen with beta 2?
Comment 3 Issue Tracker 2002-03-14 09:41:31 EST
yes, This still happens with Beta2.
Comment 4 Brian Harvell 2002-03-21 13:28:07 EST
I just tried loading beta3 on a DL380 and it's still happening :( Here is the 
last bit of the boot message.

Loading scsi_mod module
SCSI subsystem driver Revision: 1.0
Loading sd_mod module
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Loading cpqarray module
Compaq SMART2 Driver (v 2.4.5)
Found 1 controller(s)
cpqarray: Finding drives on ida0 (Integrated Array)
cpqarray ida/c0d0: blksz=512 nr_blks=35553120
cpqarray ida/c0d1: blksz=512 nr_blks=35553120
blk: queue c03d2fe0, I/O limit 4095Mb (mask 0xffffffff)
Partition check:
 ida/c0d0: p1 p2 p3
 ida/c0d1: p1
Loading jbd module
Journalled Block Device driver loaded
Loading ext3 module
Mounting /proc filesystem
Mounting root filesystem
mount: error 2 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 304k freed
Kernel panic: No init found.  Try passing init= option to kernel.
Comment 5 Jeremy Katz 2002-03-21 19:29:01 EST
Should be fixed with mkinitrd-3.3.5-1 or better
Comment 6 Matt Wilson 2002-04-01 11:08:08 EST

*** This bug has been marked as a duplicate of 62206 ***

Note You need to log in before you can comment on or make changes to this bug.