Bug 6015 - Wrong kernel is installed on laptop machines
Wrong kernel is installed on laptop machines
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-16 23:03 EDT by Dave J. Andruczyk
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 16:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave J. Andruczyk 1999-10-16 23:03:34 EDT
When installing Redhat 6.1 onto a laptop (dell Latitude CPi)
(which went fine), after booting the pcmcia ethernet  no
longer worked. The install was a "custom/everything
install".

After checking the SMP kernel which redhat has as the
default kernel had NO pcmcia modules (I donno if they are
SMP safe yet).  But for laptops there aren't any
multiprocessor laptops (yet), so why not make the default
being to use a Uni-processor kernel on ANY machine that has
pcmcia hardware detected? (which should almost ALWAYS be a
laptop, except for the rare few that have a PCMCIA interface
for their desktop machines. (they are available))


Switching lilo's default to "linux-up" and rebooting makes
everything work as normal.  Please consider this fix to
prevent less savvy laptop users from wondering why the
install works, and then networking no longer works after
booting..
Comment 1 Cristian Gafton 2000-01-04 17:20:59 EST
Assigned to dledford
Comment 2 Bernhard Rosenkraenzer 2000-02-17 08:55:59 EST
Seems to be a bug in the installer hardware detection. On a UP system, it
shouldn't install the SMP kernel... Reassigning.
Comment 3 Jay Turner 2000-02-21 16:25:59 EST
This issue is resolved in the latest beta.

Note You need to log in before you can comment on or make changes to this bug.