Bug 601539 - execute extend trace.so unsuccessfully
Summary: execute extend trace.so unsuccessfully
Status: CLOSED DUPLICATE of bug 601536
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash-trace-command   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Dave Anderson
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-08 07:13 UTC by Caspar Zhang
Modified: 2013-07-03 07:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 07:14:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Caspar Zhang 2010-06-08 07:13:25 UTC
Description of problem:

When I tried to load trace.so module in crash by using `extend /path/to/trace.so', it returns error:

extend: /usr/lib64/crash/extensions/trace.so: no commands registered: shared object unloaded

in older version (1.2.el6) this command works, I regard it as a regression.

Version-Release number of selected component (if applicable):
crash-5.0.0-14.el6
crash-trace-command-1.0-1.2.el6

How reproducible:
100%

Steps to Reproduce:
1. install crash-trace-command and run crash
2. run extend /path/to/trace.so
  
Actual results:
error occur: extend: /usr/lib64/crash/extensions/trace.so: no commands registered: shared object unloaded

Expected results:
module loaded: /usr/lib64/crash/extensions/trace.so: shared object loaded

Additional info:

Comment 1 Caspar Zhang 2010-06-08 07:14:49 UTC

*** This bug has been marked as a duplicate of bug 601536 ***


Note You need to log in before you can comment on or make changes to this bug.