Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 601542 - virt-v2v | [RFE] should check the export domain first but not fail in the last step,
virt-v2v | [RFE] should check the export domain first but not fail in the la...
Status: CLOSED DUPLICATE of bug 601535
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 03:18 EDT by Mohua Li
Modified: 2013-04-30 19:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 04:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2010-06-08 03:18:03 EDT
Description of problem:

virt-v2v should first check if the export domain is invalid, like if the images/master folder exist, if not ,give error. As now, we need to wait until the v2v generate .ovf file to know like master/vms not exist error, and before that,already finished transfer the image, convert the image,this is unreasonable, and it's time consuming.


"aug_match "/files/etc/modules.conf/alias"
aug_get "/files/etc/modules.conf/alias"
aug_set "/files/etc/modules.conf/alias/modulename" "e1000"
aug_save
aug_match "/files/boot/grub/menu.lst/title/kernel"
aug_get "/files/boot/grub/menu.lst/title/kernel"
aug_set "/files/boot/grub/menu.lst/default" "0"
aug_get "/files/boot/grub/menu.lst/title[1]/initrd"
aug_save
exists "/boot/initrd-2.4.21-50.EL.img"
mv "/boot/initrd-2.4.21-50.EL.img" "/boot/initrd-2.4.21-50.EL.img.pre-v2v"
aug_save
modprobe "ext2"
modprobe "loop"
command "/sbin/mkinitrd --with=sym53c8xx /boot/initrd-2.4.21-50.EL.img 2.4.21-50.EL"
command "/sbin/chkconfig kudzu off"
umount_all
sync
umount_all
sync
kill_subprocess
virt-v2v: Failed to create directory /tmp/NACJLJG0xI/d66ccc0c-5fb6-4ac1-bcf8-f0d4e54c2cca/master/vms/42bd32b4-7475-449c-9fe8-4c95bc4d60a1: No such file or directory
"






Version-Release number of selected component (if applicable):
virt-v2v-0.6.0.3

How reproducible:
always

Steps to Reproduce:
1,create a export domain but didn't attach to any data-center, then it won't  create the master folder under the nfs path,
2,run the virt-v2v with the export domain above,

Actual results:
fail at the last step, saying folder **/master/vms not exist

Expected results:
check the export domain first to confirm it could be used or not 

Additional info:
Comment 1 Matthew Booth 2010-06-18 04:46:19 EDT

*** This bug has been marked as a duplicate of bug 601535 ***
Comment 2 Mohua Li 2010-06-18 05:59:07 EDT
sorry for that, seems when commit, there is error, so the same bug be commited 3 times

Note You need to log in before you can comment on or make changes to this bug.