Bug 60164 - pdflatex complains about invalid entries in pdftex.map
pdflatex complains about invalid entries in pdftex.map
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 19:51 EST by Winston Chang
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 03:40:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Winston Chang 2002-02-20 19:51:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
When running pdflatex on any latex file, it gives warnings regarding entries in
pdftex.map.

Version-Release number of selected component (if applicable):
tetex-latex-1.0.7-38.2


How reproducible:
Always

Steps to Reproduce:
1. Create a latex file like this:
   \documentclass{article}
   \begin{document}
   \section{foo}
   bar
   \end{document}

2. Run pdftex on the file.

	

Actual Results:  The following errors are given:

Warning: pdflatex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry
for `rtxphvbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdflatex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry
for `rtxphvro': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdflatex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry
for `rtxptmbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdflatex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry
for `rtxptmro': SlantFont/ExtendFont can be used only with embedded T1 fonts

Expected Results:  No error should have occurred.

Additional info:

Documents usually look fine in xpdf, gv, and Acrobat Reader, but printing
certain resulting documents from Acrobat on Mac OS X results in a document that
uses Courier in place of Computer Modern in some places.  The previous example
doesn't even show up in Acrobat Reader.  I haven't checked printing from other
platforms.  The printers I used were an HP 4500 and an Apple Laserwriter 4/600 PS.

When using latex, dvips, and ps2pdf, this problem doesn't occur, even when
forcing it to use type 1 fonts.

The nature of the problem is described at
http://tug.org/pipermail/pdftex/2002-January/002119.html
Comment 1 Winston Chang 2002-02-21 15:41:42 EST
In reproduction step 2, it should say "Run pdflatex on the file" instead of pdftex.
Comment 2 Tim Waugh 2002-02-25 11:47:28 EST
I've managed to get rid of the Helvetica warnings by following the advice in
that mail, but I'm not sure exactly what the lines should look like for Times Roman.
Comment 3 Winston Chang 2002-02-25 11:58:06 EST
That message says:
-------
You can either use the close approximation to it that comes with ghostscript,
and have a map file line something like
ptmro8r NimbusRomNo9L-Regu "0.167 SlantFont" <N021003L.pfb 8r.enc
-------
Or
-------
you can trick pdftex into embedding Times Roman by not telling it the name of
the font, e.g.
ptmro8r "0.167 SlantFont" <Tir_____.pfb 8r.enc
-------

I lean toward the second method, but I'm far from being an expert on TeX and how
things should be done.  Maybe the author of the message, Robert Howlett
<rhowlett@mail.usyd.edu.au>, would know better?
Comment 4 Tim Waugh 2002-02-25 12:09:01 EST
(I have already emailed him to ask for more details.)

I favour the first method if it is possible, since it makes for smaller PDF
files.  But really, any solution would be welcome. :-)
Comment 5 Tim Waugh 2002-02-26 03:40:06 EST
(Putting a note here so I don't forget.)  Apparently this is the correct line:

rtxptmro NimbusRomNo9L-Regu "0.167 SlantFont" <n021003l.pfb tx8r.enc
Comment 6 Tim Waugh 2002-03-06 11:04:28 EST
Fixed package is 1.0.7-43.

Note You need to log in before you can comment on or make changes to this bug.