Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601663 - Python error after packages downloaded
Python error after packages downloaded
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 08:33 EDT by linux@alteeve.com
Modified: 2012-12-12 18:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 13:47:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the generated ks.cfg file that wasn't found. (2.36 KB, application/octet-stream)
2010-06-08 08:33 EDT, linux@alteeve.com
no flags Details

  None (edit)
Description linux@alteeve.com 2010-06-08 08:33:21 EDT
Created attachment 422168 [details]
This is the generated ks.cfg file that wasn't found.

Description of problem:

- While creating a new spin of Fedora Core x86_64, the error below is generated.

Version-Release number of selected component (if applicable):

- revisor-2.2-1.fc13.noarch

How reproducible:

- Only tried once.

Steps to Reproduce:
1. Start a new Fedora Core 13 x86_64 spin.
2. Select a package list with no initial ks file.
3. Begin process to generate ISO.
  
Actual results:

- Build fails to find the generated kickstart file.

Expected results:

- An ISO to be made.

Additional info:

- Here is the error text with a note at the end: http://pastebin.com/dufAdg0m
Comment 1 linux@alteeve.com 2010-06-09 00:01:12 EDT
After re-running Revisor, this time passing it the ks file attached before, I get two errors. 

The first is during during dependency resolution; It complains of not being able to find 'prctl' and 'mcelog'.

The second is the same error as in the first message; "Got an error from /usr/lib/anaconda-runtime/buildinstall (return code 1)".
Comment 2 linux@alteeve.com 2010-06-09 00:11:56 EDT
The 'mcelog' seems to have been induced when I chose i686 instead of x86_64. When I re-ran revisor again, this time choosing x86_64, it only complained of missing 'prctl'.

This third time I also started Revisor from terminal to see if there was a traceback. I got the same gnome message is in the second message, but there was no traceback, so I suspect this and the previous errors differ from the first message's error.

At this point, I've not had a successful run of Revisor.
Comment 3 linux@alteeve.com 2010-06-09 00:12:57 EDT
Sorry, after I submitted the third message, I closed the error window and the traceback appeared. Same as the first message.
Comment 4 linux@alteeve.com 2010-06-09 00:50:58 EDT
Last update for today...

I tried re-running revisor fresh, f13 x86_64. I checked none of the advanced options this time, only de-selected NetworkManager* packages and selected the Base, Gnome and Clustering groups. This time, I got the same error but the traceback was a bit different. Now it complained that:

IOError: [Errno 2] No such file or directory: '/var/tmp/revisor-install/13/f13-x86_64/x86_64/os/.discinfo'

See: http://pastebin.com/zJYbaB7n
Comment 5 G.Wolfe Woodbury 2010-10-17 07:31:36 EDT
also getting the missing .discinfo error.

Got an error from /usr/lib/revisor/scripts/DEVEL-buildinstall (return code 1)
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/revisor/modgui/ready_screen.py", line 144, in button_forward_clicked
    self.gui.next()
  File "/usr/lib/python2.6/site-packages/revisor/modgui/__init__.py", line 448, in next
    self.default[self.current]['disp'](self)
  File "/usr/lib/python2.6/site-packages/revisor/modgui/__init__.py", line 315, in displayBuildMedia
    self.BuildMedia.start()
  File "/usr/lib/python2.6/site-packages/revisor/modgui/build_media.py", line 64, in start
    self.base.lift_off()
  File "/usr/lib/python2.6/site-packages/revisor/base.py", line 884, in lift_off
    self.buildInstallationMedia()
  File "/usr/lib/python2.6/site-packages/revisor/base.py", line 1558, in buildInstallationMedia
    mypungi.ALL_workaround()
  File "/usr/lib/python2.6/site-packages/revisor/pungi.py", line 673, in ALL_workaround
    content = open(discinfofile, 'r').readlines()
IOError: [Errno 2] No such file or directory: '/var/tmp/revisor-install/rawhide/rawhide-x86_64/x86_64/os/.discinfo'
Comment 6 Bug Zapper 2011-06-02 07:36:39 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2011-06-27 13:47:15 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 8 Philip Rhoades 2012-12-12 18:43:01 EST
I still get this error with the current version of rawhide (F18/19):

IOError: [Errno 2] No such file or directory: '/var/tmp/revisor-install/rawhide/rawhide-x86_64/x86_64/os/.discinfo'

which does not seem to have anything to do with "EOL" ?

Anyone have a fix?  As someone in another post said - it would be nice if Revisor worked "out of the box".

Thanks,

Phil.

Note You need to log in before you can comment on or make changes to this bug.