Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601682 - Already-sent mails recovered in composer after crash/restart
Already-sent mails recovered in composer after crash/restart
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 09:13 EDT by David Woodhouse
Modified: 2010-11-04 05:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-2.32.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 05:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2010-06-08 09:13:47 EDT
When composing an email in Evolution, it creates ~/.evolution/.evolution-composer.autosave-XXXXXX files. When I _send_ the email, it should delete those.

It doesn't.

So when even Evolution crashes and restarts, I end up with a bunch of composer windows with mails I'd already sent.

This seems to happen after a clean shutdown/restart too.
Comment 1 Assen Totin 2010-06-13 06:09:53 EDT
Hi,

I can confirm on this. 

With F12, Evolution also used to crash/restart randomly, but at least it did not repeatedly propose to "recover" an already sent message. 

As a side note, on F12 I tried to explore the reason for these crashes; abrt re-installed half of my system with debug-enabled versions (evolution, gnome, glibc etc.) and still failed to complete a crash report. With F13, I'm not going to waste my time again. 

WWell,
Comment 2 David Woodhouse 2010-06-13 06:42:01 EDT
This seems to have gone away with the latest Fedora update.

Assen, please re-open if you can reproduce with evolution-2.30.1-8 and other current updates.
Comment 3 Assen Totin 2010-06-21 12:05:42 EDT
Hi,

I'm afraid the problem is still here.

As described by David Woodhouse, with some emails (roughly 1 in 10-20 mails; haven't spotted a particular pattern like HTML, attachments...), Evolution sends the mail, does not remove the autosave file ~/.evolution/.evolution-composer.autosave-XXXXXX, then crashes, restarts and prompts to recover the already sent message. 

[root@cfo .evolution]# rpm -qa | grep evolution
evolution-conduits-2.30.1-8.fc13.i686
evolution-2.30.1-8.fc13.i686
evolution-data-server-devel-2.30.1-2.fc13.i686
evolution-data-server-2.30.1-2.fc13.i686
evolution-devel-2.30.1-8.fc13.i686

System is F13, installed from LiveCD, all available updates applied, file system is ext4. If I can help any further with debugging, please, let me know.

WWell,
Comment 4 Milan Crha 2010-06-21 13:04:07 EDT
Thanks for a bug report and updates. I guess it's also related to changes in [1], though they may not influence this behaviour much too. Changes from [1] are applied in evolution 2.30.2, thus please give it a try when it'll pass the update process in Fedora. Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=617557
Comment 5 Assen Totin 2010-07-13 13:26:31 EDT
Hi,

Updated to 2.30.2:

[root@cfo ~]# rpm -qa | grep evolution
evolution-devel-2.30.2-1.fc13.i686
evolution-2.30.2-1.fc13.i686
evolution-conduits-2.30.2-1.fc13.i686
evolution-data-server-devel-2.30.2-2.fc13.i686
evolution-data-server-2.30.2-2.fc13.i686

The problem (random "Do you want to recover..." message) is still here. The interesting thing I only recently noticed: the message pops up only when switching to Evolution from some other task (I often use Alt+Tab and that's when I hit it). Moreover, there is no sign of a crash in Evolution (abrt is silent and it does complain when something else crashes). Could it be some other, maybe minor bug with the tmp file not being deleted upon sending the message and then, on switching back to the task, the GUI "sees" it and decides the message needs recovering? 

If I can help further, please,let me know.

WWell,
Comment 6 Milan Crha 2010-07-22 05:24:53 EDT
reopening per last comment. Might be just some coincidence, with all that asynchronous draft saving to the local disk on the first look. Are you sending the message or also closing it? And how long is the message opened before you send it? I mean, whether is the autosave file created or not before you send. The timeout for saving is about a minute.
Comment 7 Assen Totin 2010-07-26 05:54:17 EDT
Hi,

Thanks for re-opening. 

Indeed, the problem seems to only happen if the message has been manually saved as draft (Ctrl+S). I usually type my emails in the message windows, so I often hit Ctrl+S to keep a draft. When the message is ready, I use Ctrl+Enter to send it. When I go back to the main window, I'm greeted by the infamous "Do you wish tor recover..." message. 

Oddly enough, the problem does not appear if I only rely on the autosave of Evolution. (It's just that I'm not certain how reliable it is; on the other hand, I sometimes have to save drafts between sessions, or start a draft in the office and complete it at home etc.). 

If I can help further, please, let me know.

WWell,
Comment 8 Milan Crha 2010-07-30 08:30:11 EDT
I can reproduce this with 2.30.2, with steps:
a) open composer, write some text to body and such
b) wait until it creates an autosave file in ~/.evolution
c) modify message body again, and use Ctrl+S to safe a draft
d) wait another minute, see no update on the autosave file (by time/file size)
e) modify message body and send it
Result: autosave file is still there

But when I try the same on actual git master (just before 2.31.6) then the autosaved file is properly removed.
Comment 9 Assen Totin 2010-11-03 16:42:46 EDT
Hi,

The bug seems gone in Fedora 14, evolution-2.32.0-2.fc14. Any objection to closing the report?

WWell,
Comment 10 Milan Crha 2010-11-04 05:46:55 EDT
Thanks for testing. Not from my side, and it's true that there were done couple changes in this area in 2.32.0. I'm closing this for David, but feel free to reopen if you face with 2.32.0 or later.

Note You need to log in before you can comment on or make changes to this bug.