Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601707 - No customization option during install
No customization option during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 09:48 EDT by John Aldrich
Modified: 2010-06-08 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 10:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Aldrich 2010-06-08 09:48:00 EDT
Description of problem:
Downloaded and burned the F13 DVD. This morning I went to do an upgrade of my F12 system and it got as far as selecting what drives I want to mount and where I want to install the boot loader. Then it went straight into installing packages without offering to customize the partitions or packages.

Version-Release number of selected component (if applicable):


How reproducible:
Dunno. This is the only system I've tried it on.

Steps to Reproduce:
1.Burn DVD
2.Boot DVD on an existing install
3.select "upgrade existing install" at DVD boot
  
Actual results:
Once existing drives are selected, install begins w/o confirmation or customization of packages or partitions

Expected results:
Anaconda should ask you to select packages and partitions.

Additional info: My system has a mix of PATA and SATA. I'm trying to install onto the SATA drive.
Comment 1 Chris Lumens 2010-06-08 10:08:47 EDT
Upgrades do not offer the ability to customize partitions or packages.  An upgrade is a simple package upgrade of what you've already got installed to the latest versions in the released product.  This is working as intended.
Comment 2 John Aldrich 2010-06-08 10:24:13 EDT
Perhaps someone should have Anaconda put up a notification to that effect, in order to prevent heart attacks? I mean, just a simple notification to the effect of "NOTICE: By selecting 'Upgrade an existing installation' you will not be able to select packages or customize your partitioning scheme. Continue y/n?" would do it.
Comment 4 John Aldrich 2010-06-08 10:52:59 EDT
So, Chris, you expect the hobby user to actually *read* the documentation before upgrading? Get real. :-) Seriously. How hard would it be to put a sanity warning into Anaconda on an upgrade, especially when upgrading from DVD/CD. All I'm asking for is a little "anti-heart-attack insurance."

Note You need to log in before you can comment on or make changes to this bug.