Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 601715 - jmx plugin: conn props for various JVM services (Memory Pool, etc.) should be read-only
jmx plugin: conn props for various JVM services (Memory Pool, etc.) should be...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.3.1
All All
low Severity low (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: 725852
  Show dependency treegraph
 
Reported: 2010-06-08 10:01 EDT by Ian Springer
Modified: 2013-08-05 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2010-06-08 10:01:15 EDT
The Object Name, Name Template, Description Template, and Name properties on the various JVM services should all be defined as read-only in the jmx plugin's descriptor - Object Name and Name because they include the Resource key, and the Template properties because they are only used during discovery and changing them would serve no purpose.
Comment 1 Ian Springer 2010-09-24 20:20:22 EDT
Fixed in master via commit 978e646.
Comment 2 Sunil Kondkar 2010-10-21 03:47:23 EDT
Verified in RHQ build#438

The Object Name, Name Template, Description Template, and Name properties on
the JVM services are read only in 'Inventory->Connection settings' subtab.
Comment 3 Corey Welton 2011-05-23 21:09:56 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.