Bug 601782 - rc.sysinit/S00microcode_ctl causing kernel panic.
rc.sysinit/S00microcode_ctl causing kernel panic.
Status: CLOSED DUPLICATE of bug 591784
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 11:35 EDT by Tudor Georgescu
Modified: 2010-11-11 14:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 10:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tudor Georgescu 2010-06-08 11:35:08 EDT
Description of problem:
Build RHEL 6 beta on X3650 M2 system. Created a VM, no issues. Attempting to boot VM fails and hangs at various stages of boot, always with the same result. udev sometimes starts, networking sometimes starts, but it always produces the below error. Very inconsistent when the kernel panic actually happens, but always on boot.

Version-Release number of selected component (if applicable):
RHEL6.0-20100414.0-AP-x86_64-DVD1.iso

How reproducible:
Boot VM.

Steps to Reproduce:
1. Boot VM.
2. Edit grub to turn off 'rhgb' and 'quiet'
3. Boot.
  
Actual results:
           Welcome to RedHat Enterprise Linux
           Press 'I' to enter interactive startup.
Starting udev: /etc/rc.d/rc.sysinit: line 316:   417 Killed
/sbin/start_udev
init: rcS main process (394) killed by KILL signal
/etc/rc3.d/S00microcode_ctl: line 52: syntax error near unexpected token `}'
/etc/rc3.d/S00microcode_ctl: line 52: `}' Kerne; panic - not syncing: Out of memory and no killable processes... 

Expected results:
VM to boot normally!

Additional info:
VM built with the following command:

virt-install --accelerate --hvm --connect qemu:///system --name foo-test --ram 1024 --file=/local/foo-test.img --file-size=6 --vnc --cdrom=/local/RHEL6.0-20100414.0-AP-x86_64-DVD1.iso --network bridge=foobridge
Comment 2 RHEL Product and Program Management 2010-06-08 11:53:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bill Nottingham 2010-06-08 15:07:44 EDT
The microcode_ctl error is unrelated... perhaps this is the balloon driver bug?
Comment 4 Alex Williamson 2010-06-09 14:33:18 EDT
Please try the workaround in bug 591784, particularly the bit about blacklisting virtio_balloon (echo "blacklist virtio_balloon" >> /etc/modprobe.d/blacklist.conf
) and report back if that solves the problem.  You may need to boot the VM with the DVD in rescue mode to be able to make this change on the VM filesystem.
Comment 5 Tudor Georgescu 2010-06-10 06:55:51 EDT
Cheers Alex. Definitely a dupe of bug 591784. Blacklisting virtio_balloon worked.
Comment 6 Alex Williamson 2010-06-10 10:06:04 EDT

*** This bug has been marked as a duplicate of bug 591784 ***

Note You need to log in before you can comment on or make changes to this bug.