Bug 601811 - yum update --skip-broken encoding problem
yum update --skip-broken encoding problem
Status: CLOSED DUPLICATE of bug 601498
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 12:49 EDT by Milos Jakubicek
Modified: 2014-01-21 18:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 12:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Jakubicek 2010-06-08 12:49:54 EDT
Description of problem:

yum update --skip-broken with Czech locale (cs_CZ.UTF-8) fails with:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 150, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 870, in buildTransaction
    (rescode, restring) = self._doSkipBroken(rescode, restring)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 895, in _doSkipBroken
    rescode, restring = self._skipPackagesWithProblems(rescode, restring)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 965, in _skipPackagesWithProblems
    rescode, restring = self.resolveDeps(True)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 691, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 793, in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 275, in _processReq
    self.po_with_problems.add((po,self._working_po,str(e)))
UnicodeEncodeError: 'ascii' codec can't encode characters in position 4-5: ordinal not in range(128)

Version-Release number of selected component (if applicable):

yum-3.2.27-4.fc13.noarch

Changing "str(e)" to "unicode(e)" on depsolve.py:275 solves the problem, though I'm not sure if this is the proper solution.
Comment 1 seth vidal 2010-06-08 12:52:05 EDT

*** This bug has been marked as a duplicate of bug 601498 ***

Note You need to log in before you can comment on or make changes to this bug.