Bug 60183 - Intermittent gcc internal errors compiling kde
Intermittent gcc internal errors compiling kde
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-21 10:23 EST by Bryce Nesbitt
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-21 10:23:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2002-02-21 10:23:32 EST
I get periodic gcc internal errors compiling kde.  I have to restart the compile
several
times for it to finish:

c++ -DHAVE_CONFIG_H -I. -I. -I.. -I/home/bryce/kdetest/include
-I/home/bryce/cvs/kde/qt-copy/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT
-D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wbad-function-cast -Wundef -Wall
-pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -fno-builtin -g -O2
-fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT
-DQT_NO_ASCII_CAST -Wp,-MD,.deps/kwinbutton.pp -c kwinbutton.cpp  -fPIC -DPIC -o
.libs/kwinbutton.o
kwinbutton.cpp: In method `KWinInternal::KWinToolTip::~KWinToolTip ()':
kwinbutton.cpp:80: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
gmake[3]: *** [kwinbutton.lo] Error 1
gmake[3]: Leaving directory `/mnt/bigstuff/cvs/kde/kdebase/kwin'

HardHat:kdebase> gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)

It's not repeatable on any one file.  Usually if I cd to the directory in
question and
gmake there, I can get past the blockage.  I know it does not make any sense.
Comment 1 Jakub Jelinek 2002-02-22 08:55:11 EST
It makes sense. In 99% of cases something like this has been reported,
it has been because of flaky hardware.

Note You need to log in before you can comment on or make changes to this bug.