Bug 601897 - (CVE-2010-2190, MOPS-2010-047, MOPS-2010-048) CVE-2010-2190 php: interruption vulnerabilities in trim and substr_replace (MOPS-2010-047, MOPS-2010-048)
CVE-2010-2190 php: interruption vulnerabilities in trim and substr_replace (M...
Status: CLOSED DUPLICATE of bug 169857
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Red Hat Product Security
impact=none,public=20100531,reported=...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 16:25 EDT by Vincent Danen
Modified: 2015-08-19 04:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 05:13:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MOPS-2010-047 reproducer (1.23 KB, text/plain)
2010-07-23 16:42 EDT, Tomas Hoger
no flags Details
MOPS-2010-048 reproducer (2.15 KB, text/plain)
2010-07-23 16:43 EDT, Tomas Hoger
no flags Details

  None (edit)
Description Vincent Danen 2010-06-08 16:25:42 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2010-2190 to
the following vulnerability:

The (1) trim, (2) ltrim, (3) rtrim, and (4) substr_replace functions
in PHP 5.2 through 5.2.13 and 5.3 through 5.3.2 allow
context-dependent attackers to obtain sensitive information (memory
contents) by causing a userspace interruption of an internal function,
related to the call time pass by reference feature.

References:
http://www.php-security.org/2010/05/30/mops-2010-047-php-trimltrimrtrim-interruption-information-leak-vulnerability/index.html
http://www.php-security.org/2010/05/30/mops-2010-048-php-substr_replace-interruption-information-leak-vulnerability/index.html
Comment 1 Tomas Hoger 2010-07-23 11:08:06 EDT
Upstream patch added to Zend engine's zend_parse_parameters to address MOPS-2010-006 addcslashes interruption vulnerability (bug #617578, comment #2) addresses trim MOPS-2010-047 too:
  http://svn.php.net/viewvc?view=revision&revision=298945

This fix is included in 5.3.3.
Comment 2 Tomas Hoger 2010-07-23 16:42:53 EDT
Created attachment 434064 [details]
MOPS-2010-047 reproducer
Comment 3 Tomas Hoger 2010-07-23 16:43:48 EDT
Created attachment 434065 [details]
MOPS-2010-048 reproducer
Comment 4 Tomas Hoger 2010-07-23 16:49:02 EDT
Upstream commit for the substr_replace issue:
  http://svn.php.net/viewvc?view=revision&revision=299242

Fixed in 5.3.3 too:
  http://www.php.net/releases/5_3_3.php
Comment 5 Tomas Hoger 2010-07-26 05:13:23 EDT
Closing this, see bug #617578, comment #3 for more detailed explanation.

*** This bug has been marked as a duplicate of bug 169857 ***
Comment 6 Tomas Hoger 2010-07-26 05:13:40 EDT
Statement:

Red Hat does not consider interruption issues allowing safe_mode / open_basedir
restriction bypass to be security sensitive.  For more details see
https://bugzilla.redhat.com/show_bug.cgi?id=169857#c1 and
http://www.php.net/security-note.php

Note You need to log in before you can comment on or make changes to this bug.