Bug 601938 - SELinux is preventing /bin/rm "unlink" access on mysql.sock.
SELinux is preventing /bin/rm "unlink" access on mysql.sock.
Status: CLOSED DUPLICATE of bug 601937
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:240f62f7fa5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 17:33 EDT by Daniel Scott
Modified: 2010-06-09 04:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 04:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Scott 2010-06-08 17:33:16 EDT
Summary:

SELinux is preventing /bin/rm "unlink" access on mysql.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by rm. It is not expected that this access is
required by rm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:mysqld_safe_t:s0
Target Context                unconfined_u:object_r:mysqld_db_t:s0
Target Objects                mysql.sock [ sock_file ]
Source                        rm
Source Path                   /bin/rm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.4-6.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-112.fc13.x86_64 #1
                              SMP Thu May 27 02:28:31 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 08 Jun 2010 04:58:42 PM EDT
Last Seen                     Tue 08 Jun 2010 04:58:42 PM EDT
Local ID                      95a5bb45-3f62-48f3-80ab-5717132108b2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276030722.905:3159262): avc:  denied  { unlink } for  pid=592 comm="rm" name="mysql.sock" dev=dm-1 ino=262426 scontext=unconfined_u:system_r:mysqld_safe_t:s0 tcontext=unconfined_u:object_r:mysqld_db_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1276030722.905:3159262): arch=c000003e syscall=263 success=yes exit=0 a0=ffffffffffffff9c a1=18590c0 a2=0 a3=7fffca3963d0 items=0 ppid=495 pid=592 auid=768 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts11 ses=1 comm="rm" exe="/bin/rm" subj=unconfined_u:system_r:mysqld_safe_t:s0 key=(null)



Hash String generated from  catchall,rm,mysqld_safe_t,mysqld_db_t,sock_file,unlink
audit2allow suggests:

#============= mysqld_safe_t ==============
allow mysqld_safe_t mysqld_db_t:sock_file unlink;
Comment 1 Miroslav Grepl 2010-06-09 04:11:35 EDT

*** This bug has been marked as a duplicate of bug 601937 ***

Note You need to log in before you can comment on or make changes to this bug.