Bug 601948 - spamassassin-3.2.5 too old to be useful
spamassassin-3.2.5 too old to be useful
Status: CLOSED DUPLICATE of bug 481616
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spamassassin (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Jonathan Blandford
qe-baseos-daemons
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 18:07 EDT by James Ralston
Modified: 2013-04-02 00:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 02:32:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2010-06-08 18:07:35 EDT
RHEL5.5 provides spamassassin-3.2.5-1.el5.

Although it appears to have been largely unannounced by the SpamAssassin developers, the 3.2.x series is now in "maintenance mode", which means the only rule updates that are pushed to it are emergency updates:

http://marc.info/?l=spamassassin-users&m=127440417913677&w=2

SpamAssassin's effectiveness is largely dependent on timely rule updates. From scoring sample spam messages with both 3.2.5 and 3.3.1, and by diffing the latest rulesets available for both versions, I have found that 3.2.5's ability to detect spam has been non-trivially compromised by the discontinuation of regular rule updates.

(In fact, I discovered that 3.2.x had been deprecated while investigating why the RHEL5 SpamAssassin fared poorly at identifying recent spam messages we've been receiving.)

I can sympathize that SpamAssassin didn't provide much notice, but you are doing your customers a disservice by shipping this deprecated version of SpamAssassin as the latest available for RHEL5. Please update to at least 3.3.0 (preferably 3.3.1) ASAP.
Comment 1 James Ralston 2010-06-08 18:13:21 EDT
Cross-filed as Service Request 2029372.
Comment 2 Subhendu Ghosh 2011-02-01 02:32:25 EST

*** This bug has been marked as a duplicate of bug 481616 ***

Note You need to log in before you can comment on or make changes to this bug.