Bug 601989 - Creating new fuse-encfs filesystem fails with 'boost::filesystem::filesystem_error'
Creating new fuse-encfs filesystem fails with 'boost::filesystem::filesystem_...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: fuse-encfs (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 20:43 EDT by andrew
Modified: 2012-08-21 14:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 14:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec for fuse-encfs-1.7.4 ported from Fedora 13 spec (11.64 KB, text/plain)
2011-04-05 07:39 EDT, Tomasz Ostrowski
no flags Details

  None (edit)
Description andrew 2010-06-08 20:43:20 EDT
Description of problem:

Creating a new fuse-encfs filesystem fails with boost library error:

terminate called after throwing an instance of
'boost::filesystem::filesystem_error'
  what():  boost::filesystem::path: invalid name ".encfs6.xml" in
path: "/tmp/crypt-raw/.encfs6.xml"
Aborted 

Version-Release number of selected component (if applicable):

fuse-encfs-1.4.2-1.el5 (epel)

How reproducible:

Everytime on CentOS 5.5 (i386).

Steps to Reproduce:
1. yum install fuse-encfs
2. mkdir /tmp/crypt-raw /tmp/crypt
3. encfs /tmp/crypt-raw /tmp/crypt
4. select 'p' for pre-configured paranoia & enter a password.
  
Error message is printed after attempting to create new encfs filesystem.

Actual results:

Error message as above.

Expected results:

File system should be mounted

Additional info:

Josh Kayse is aware of this issue and asked for this bug to be filed.

Error does not occur when mounting existing fuse-encfs filesystem, only when creating a new one.

The Dag Wieers build of fuse-encfs-1.4.1-1.el5.rf.i386.rpm does not have this issue.
Comment 1 Tomasz Ostrowski 2011-04-05 07:39:59 EDT
Created attachment 489967 [details]
Spec for fuse-encfs-1.7.4 ported from Fedora 13 spec

I'm attaching a spec file I've created for latest encfs-1.7.4 ported and updated from Fedora 13 to EPEL. It uses boost141 from EPEL instead of RHEL boost, as the latter is not supported by encfs.

I've tested build on i386 and x86_64 - it builds cleanly with mock and works on CentOS 5.5.

As current encfs in EPEL simply does not work I think a major upgrade is reasonable and complies with update policy.
Comment 2 Josh 2011-04-10 12:30:07 EDT
I would tend to agree that we should update to 1.7.4 as it resolves some additional security relevant bugs.
Comment 3 Peter Lemenkov 2011-04-11 08:18:26 EDT
Unfortunately encfs requires boost >= 1.34 and we have only 1.33.1 in EL-5.

Has anybody tried to patch encfs to allow building against boost-1.33.1?
Comment 4 Till Maas 2012-06-19 06:57:34 EDT
(In reply to comment #3)
> Unfortunately encfs requires boost >= 1.34 and we have only 1.33.1 in EL-5.
> 
> Has anybody tried to patch encfs to allow building against boost-1.33.1?

As written in comment 1 there is boost141 in EPEL which provides a newer version of boost. Is this not enough? Since encfs is broken now for two years in EPEL 5, please respond whether you are still intending to maintain it and orphan it, if not. Also please consider this to be the first message regarding the nonresponsive package mainater procedure:
https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

I hope you simply missed the possibility to use boos141 and can prepare an update soon.
Comment 5 Peter Lemenkov 2012-06-19 07:15:27 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Unfortunately encfs requires boost >= 1.34 and we have only 1.33.1 in EL-5.
> > 
> > Has anybody tried to patch encfs to allow building against boost-1.33.1?
> 
> As written in comment 1 there is boost141 in EPEL which provides a newer
> version of boost. Is this not enough? Since encfs is broken now for two
> years in EPEL 5, please respond whether you are still intending to maintain
> it and orphan it, if not. Also please consider this to be the first message
> regarding the nonresponsive package mainater procedure:
> https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers
> 
> I hope you simply missed the possibility to use boos141 and can prepare an
> update soon.

I don't use encfs anymore so feel free to take it over.
Comment 6 Fedora Update System 2012-07-11 18:07:24 EDT
fuse-encfs-1.7.4-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fuse-encfs-1.7.4-7.el5
Comment 7 Fedora Update System 2012-07-12 18:33:30 EDT
Package fuse-encfs-1.7.4-7.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fuse-encfs-1.7.4-7.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6382/fuse-encfs-1.7.4-7.el5
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-21 14:36:49 EDT
fuse-encfs-1.7.4-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.