This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 6020 - RFE: /bin proceeds /usr/bin in root's PATH
RFE: /bin proceeds /usr/bin in root's PATH
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-17 02:53 EDT by river
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 15:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description river 1999-10-17 02:53:03 EDT
The syntax hilighting feature of vim do not appear to have
support compiled into the version distributed with Red Hat
Linux 6.1.  This feature worked fine with 6.0.  I am using
the command ':syntax on' to produce the error that the
command is unsupported.
Comment 1 Bill Nottingham 1999-10-17 17:37:59 EDT
Works for me here. Do you only have vim-minimal installed?
Comment 2 river 1999-10-17 19:43:59 EDT
I have the following vim related packages installed:

vim-minimal
vim-enhanced
vim-common
vim-X11

I have reverted back to version 5.3-7 of the packages.  When using
version 5.4-2, I receive the following message:

Error detected while processing /root/.vimrc:
line   11:
Sorry, this command is not implemented: :syntax on

My .vimrc follows:

:if has("terminfo")
:  set t_Co=8
:  set t_Sf=p1%dm
:  set t_Sb=p1%dm
:else
:  set t_Co=8
:  set t_Sf=dm
:  set t_Sb=dm
:endif

:syntax on
Comment 3 Bill Nottingham 1999-10-18 09:24:59 EDT
Hmm... most likely /bin is in root's path before /usr/bin, and
you're running /bin/vi, which is the 'minimal' version of vim.
Comment 4 river 1999-11-01 00:22:59 EST
The comment about the path is correct.  The minimal version of vi in
/bin is being called before /usr/bin/vi.  As the default path sets
/bin before /usr/bin for both normal and root users, /bin/vi will
always be called.

The default path in v6.0 seems to place /usr/bin before bin (although,
this is not in agreement with the documentation on 'login').  Maybe
this was a fix for the 'login' program in v6.1?  Anyhow, what the
default behaviour should be I'll leave up to the experts there at Red
Hat.  I'm happy enough with it either way, as long as it's working.
Comment 5 Michael K. Johnson 1999-11-22 15:16:59 EST
I've changed the component to util-linux (it includes login), but
it's not just util-linux, that's just the first place to fix this.
util-linux, gdm, xdm, and kdm are a minimal list of places that
this needs to be fixed.  Note that gdm at least as a RootPath
configuration option that can be used to set this; the rest have
compiled-in paths.

No matter what we change it to, someone will complain, but
/usr/sbin:/usr/bin:/sbin:/bin should work the best for the
most people.
Comment 6 Jeff Johnson 2000-07-31 16:34:14 EDT
DEFERRED until after Winston.

Note You need to log in before you can comment on or make changes to this bug.