Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602005 - enable tests repository in every provisioned system
enable tests repository in every provisioned system
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.5
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 21:14 EDT by Hushan Jia
Modified: 2015-05-03 23:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 23:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hushan Jia 2010-06-08 21:14:34 EDT
Description of problem:
It is very often that we take a system, install some tests, and run them manually, to make things convenient, so could you add the harness repo and the tests repo when install the system, just as like beaker-os repo.

I think it is simply add

repo --name="beaker-harness" --baseurl=http://download.devel.redhat.com/yum/redhat/rhts/harness/
repo --name="rhts tests development" --baseurl=http://rhts.redhat.com/rpms/development/noarch/noarch

into the anaconda kickstart file for installation.


Version-Release number of selected component (if applicable):
Version - 0.5.41 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marian Csontos 2010-06-09 02:55:52 EDT
This works as you said when "Schedule > Reserve" is used instead of System > Take.

Is there any particular reason for not using Reserve?
Comment 2 Hushan Jia 2010-06-10 03:20:53 EDT
I am not sure how the system list is generated when I click the show systems button, but I cant find the many system I want to reserve, the only way is to goto machine page and take, or use legacy rhts reserve workflow.
Comment 3 Raymond Mancy 2010-06-10 04:08:56 EDT
Hushan, can you give specific details so we verify it is/isn't working as expected ?

Thanks
Comment 4 Hushan Jia 2010-06-10 06:19:57 EDT
Hi Raymond, the problem is the system list showed by show systems in scheduler/reserve is less than I search the systems/available, so that I met this problem, the machine I wnat to reserve is not in the list.
Comment 5 Raymond Mancy 2010-06-10 19:32:52 EDT
Hi Hushan,
There are other factors at play though,like what distro's a machine can support.
Comment 6 Hushan Jia 2010-06-10 20:47:28 EDT
This is an example, at scheduler/reserve page, select the Reserve Criteria:
Arch: i386
Distro Family: RedHatEnterpriseLinux6
Method: nfs
Tag: STABLE
Select Distro: RHEL6.0-20100603.1_nfs server i386

then do show systems, there is no amd-dinar systems which is I want to reserve.
Comment 7 Raymond Mancy 2010-06-10 21:55:52 EDT
Hi Hushan,
I didn't check all the dinar machines, but at least on amd-dinar-01.lab.bos.redhat.com you need to be in one of the following groups

 Kernel Hardware  	   	
 Release Test Team 	
 Kernel QE 	
 Virt QE 		
 kernel-adm 	

I had a quick look and I couldn't see you were in any of them.
Comment 8 Hushan Jia 2010-06-10 22:01:34 EDT
Hi Raymond, I am in Kernel QE, and I can take it in the machine page...
Comment 9 Raymond Mancy 2010-06-10 23:50:40 EDT
Ok, this looks like it could be a bug. 
The following query:
return query.filter(and_(
                                System.status==SystemStatus.by_name(u'Working'),
                                    or_(and_(System.owner==user,
                                             System.loaned==None),
                                      System.loaned==user,
                                      and_(System.shared==True,
                                           System.groups==None,
                                           System.loaned==None
                                          ),
                                      and_(System.shared==True,
                                           System.loaned==None,
                                           User.user_id==user.user_id
                                          )
                                       )
                                           )
                                      )

Says to me that a machine that has a group is never available,even to those who are part of a group that has the system.
Is this expected behaviour Bill ?
Comment 10 Hushan Jia 2010-07-13 21:43:09 EDT
Hi, still not able to queue reservation on those machine which I am in the group, the only way to reserve these machine is to use legacy rhts reserve workflow, so would you consider this a blocker? any update on this?
Comment 11 Bill Peck 2010-07-20 10:58:14 EDT
I'm denying the beaker-blocker on this.  Since we didn't have that functionality previously.

I recognise there is an issue with the reservation code, I believe thats covered by this bz 612710
Comment 12 Marian Csontos 2010-08-09 08:08:37 EDT
Folks, this BZ diverted from what's in Subject/Description. Clean it up please.

Thanks.
Comment 13 Raymond Mancy 2010-08-09 23:03:24 EDT
Closing,the original problem described in this bug is fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.