Bug 60202 - SMBD takes lots or memory in samba 2.0.10-0.7 (redhat build)
SMBD takes lots or memory in samba 2.0.10-0.7 (redhat build)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
http://groups.google.com/groups?hl=en...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-21 16:31 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 12:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-21 16:31:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Each SMBD process takes up lots of memory compared to other versions of samba.
If the [printers] share is enabled with a large printcap file, the problem is
ampified.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use large printcap file
2.enbale [printers] share in smb.conf
3.#service smb restart
4.ps aux | grep smbd 
5.note memory usage
6.remove [printers] share in smb.conf
7.ps aux | grep smbd
8.note memory usage
9.repeate with contemporary samba build and note how much each smbd process takes.
5.#
	

Actual Results:  smbd processes take large amounts of memory, 10x previous samba
builds.

Expected Results:  smbd processes should take a resonable amount of memory.

Additional info:

It the amount of memory used per smbd process seems to be related to the number
of shares. Previous samba builds 1.9.x and 2.2.x do not take 1/10 to 1/2 the
memory of smbd processes in 2.0.7 - 2.0.10
Comment 1 Andrew Bartlett 2002-03-24 04:44:00 EST
As the Google thread indicates, this bug has been fixed in the currently
maintained branches of 2.2 and HEAD - Including (I think) the version RedHat is
now shipping.

Comment 2 Trond Eivind Glomsrxd 2002-04-03 12:29:17 EST
There are 2.2.3a rpms available at http://people.redhat.com/teg/samba/ - can you
give them a try?
Comment 3 Trond Eivind Glomsrxd 2002-07-24 19:00:22 EDT
Since the samba developer says it's fixed and no feedback to the contrary is
given, I'll close this.

Note You need to log in before you can comment on or make changes to this bug.