Bug 60212 - g++ in hampton seems to be confused about its headers
Summary: g++ in hampton seems to be confused about its headers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-22 02:49 UTC by Michal Jaegermann
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 15:23:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2002-02-22 02:49:52 UTC
Description of Problem:

During a compilation the following happens:

In file included from /usr/include/g++-v3/backward/algo.h:61,
                 from bon_time.cpp:19:
/usr/include/g++-v3/backward/tempbuf.h:70: `get_temporary_buffer' not declared
/usr/include/g++-v3/backward/tempbuf.h:71: `return_temporary_buffer' not 
   declared
make: *** [bon_time.o] Error 1

This is, BTW, result of trying to compile bonnie++-1.02a.  Never mind
that bonnie sources and 'configure' seem to be very confused, and that it
not very hard to fix _that_ one (few ways but commenting out apparently
bogus '#define USE_STL' seems to be the simplest), but headers should not
trip on symbols they include themselves.  Both `get_temporary_buffer'
and `return_temporary_buffer' are not coming from bonnie.

Comment 1 Jakub Jelinek 2002-02-27 11:09:34 UTC
This was fixed in CVS a few days ago.

Comment 2 Jay Turner 2002-03-20 15:18:21 UTC
Can you confirm this is fixed in Beta 2?

Comment 3 Jakub Jelinek 2002-03-20 15:23:19 UTC
Yes, it is (in 3.1-0.22 and above).
Though we used just gcc-2.96-RH in beta2 (where this never existed)
and in skipjack 3.1 might be just in preview/.


Note You need to log in before you can comment on or make changes to this bug.