Bug 60215 - New chkconfig option
Summary: New chkconfig option
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-22 04:00 UTC by Mike Chambers
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 20:38:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Chambers 2002-02-22 04:00:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
To add an option to chkconfig to enable a file/script to be converted and used 
in /etc/rc[0-6].d

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.man chkconfig
2.
3.
	

Actual Results:  There are no results currently for this type option

Expected Results:  With an option in chkconfig a user can convert his 
script/file so that it can be included with the rest of the scripts 
in /etc/init.d/ directory.

Additional info:

This could be done somehow by the command with option checking for the 
beginning of the file (maybe for something in particular if needed) and adding 
the default information.  Then it would search for the bottom of the file and 
add there the appropriate information.  This could be, for instance, default 
run levels of 345 to start/remove from as well as a restart/reload or whatever.

Comment 1 Bill Nottingham 2002-02-22 16:31:33 UTC
That's not the correct way to go about this; the correct way is to have a decent
documentation example so users can write their own scripts...

Comment 2 Mike Chambers 2002-02-23 00:28:06 UTC
So your recommending a good documented template be setup/used for users to do 
this.  Then is that done?  How bout keeping this open and doing that then at 
least or stashing it away as a TODO?

Comment 3 Mike Chambers 2003-04-03 03:17:37 UTC
ping

Comment 4 Bill Nottingham 2003-04-03 04:05:23 UTC
Not done due to lack of time.

Comment 5 Mike Chambers 2003-04-03 04:07:57 UTC
Ok, but wanted to do a status check as it had been over a year since last reply.

Comment 6 Mike Chambers 2004-08-13 13:15:01 UTC
anything ever came of this as of yet?

Comment 7 Bill Nottingham 2004-08-13 14:32:02 UTC
No.

Comment 8 Bill Nottingham 2005-02-02 20:38:12 UTC
This is probably best handled in the sysvinitfiles portion of
initscripts, not in chkconfig itself.


Note You need to log in before you can comment on or make changes to this bug.