Bug 602235 - emacs under root using the wrong config file
Summary: emacs under root using the wrong config file
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Karel Klíč
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-09 12:58 UTC by Ales Kozumplik
Modified: 2014-09-30 23:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 13:44:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ales Kozumplik 2010-06-09 12:58:00 UTC
1) gnome terminal is running
2) I do su, enter password, become root
3) $ emacs something
4) I get:

Warning (initialization): An error occurred while loading `/home/akozumpl/.emacs':

The point is, I am root, $HOME is /root etc. so no matter what emacs thinks I am, the config should be loaded from /root/.emacs. the non-root config file can reference $HOME so if this is an intended feature it doesn't work anyway.

Comment 1 Jonathan Underwood 2010-06-09 13:44:03 UTC
su with out the -l starts a non login shell, and so root's startup files are not read. So this is working as designed - you need to use su -l.


Note You need to log in before you can comment on or make changes to this bug.