Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602239 - docs are not valid xml
docs are not valid xml
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pacemaker (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Beekhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 09:00 EDT by Dan Horák
Modified: 2011-01-19 03:06 EST (History)
7 users (show)

See Also:
Fixed In Version: pacemaker-1.1.2-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-19 03:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for the docs (704 bytes, application/octet-stream)
2010-06-10 07:01 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2010-06-09 09:00:37 EDT
Description of problem:
version 1.6.3 of publican breaks pacemaker builds due an error during documentation generation

Version-Release number of selected component (if applicable):
publican-1.6.3-0.fc13


Steps to Reproduce:
1. do a build of pacemaker (eg. a scratch build in koji - http://koji.fedoraproject.org/koji/taskinfo?taskID=2240497)
  

Additional info:
log from successful build using publica 1.6.2 - http://kojipkgs.fedoraproject.org/packages/pacemaker/1.1.2/1.fc13/data/logs/x86_64/build.log
log with an error - http://koji.fedoraproject.org/koji/getfile?taskID=2240501&name=build.log

or on Fedora/s390x is much cleaner situation - the difference between the 2 buildroots is only in the publican package (1.6.2 vs. 1.6.3), see
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=165487
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=165475

It's quite possible that the pacemaker docs have problem, because the error is about validation, but in that case I would appreciate help or pointers.
Comment 1 Ruediger Landmann 2010-06-09 10:03:22 EDT
The XML is invalid. 

The content model for <imagedata> is EMPTY[1] and therefore this tag must not contain data.

However, in the Book_Info.xml file in pacemaker-1.1.2-1.fc13.src.rpm, I found:

<imageobject>
    <imagedata fileref="Common_Content/images/title_logo.svg" format="SVG">
    </imagedata>
</imageobject>

Here, the <imagedata> tag contains the spaces used to indent the closing tag on the following line.

Changing this to

<imageobject>
    <imagedata fileref="Common_Content/images/title_logo.svg" format="SVG"/>
</imageobject>

or 

<imageobject>
    <imagedata fileref="Common_Content/images/title_logo.svg" format="SVG"/></imagedata>
</imageobject>

fixes the problem and lets the doc build normally on my system. If you make this change, can you build on Koji successfully?

Cheers
Rudi


[1] http://www.docbook.org/tdg/en/html/imagedata.html
Comment 2 Ruediger Landmann 2010-06-09 10:05:03 EDT
(In reply to comment #1)

> <imageobject>
>     <imagedata fileref="Common_Content/images/title_logo.svg"
> format="SVG"/></imagedata>
> </imageobject>

Sorry -- this should be

<imageobject>
    <imagedata fileref="Common_Content/images/title_logo.svg" 
format="SVG"></imagedata>
</imageobject>

of course...
Comment 3 Dan Horák 2010-06-10 06:59:25 EDT
Ruediger, thanks, with that update pacemaker builds fine on F-13 with publican 1.6.3. But when testing the builds I have found that latest publican in Rawhide is 1.6.2 because the 1.6.3 build failed there.

I am switching the component to pacemaker and updating the summary because the real bug is there.
Comment 4 Dan Horák 2010-06-10 07:01:50 EDT
Created attachment 422861 [details]
fix for the docs
Comment 5 Andrew Beekhof 2010-06-11 08:29:41 EDT
Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.