Bug 602375 - Yum performed incorrect N-V-R comparison for NetworkManager
Yum performed incorrect N-V-R comparison for NetworkManager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 14:10 EDT by Michel Alexandre Salim
Modified: 2014-01-21 18:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 14:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2010-06-09 14:10:16 EDT
Description of problem:
During the F-13 beta process, the following packages were shipped:
NetworkManager{,-{glib,gnome}}-0.8.0-0.4.git20100211.fc13.x86_64
initscripts-9.11-1.fc13.x86_64

These were upgraded in F-13 final:
NetworkManager to 0.8.1-0.1.git20100510.fc13.x86_64
initscripts to 9.12-1.fc13.x86_64

However, using yum to update NetworkManager fails, apparently 0.8.0 ">=" 0.8.1. updating initscripts fails as it conflicts with NM 0.8.0 (so the failure to update NM blocks the initscripts update).

Updating via rpm -Uvh works as expected

Version-Release number of selected component (if applicable):
yum-3.2.27-4.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. Download the older NM and initscripts RPMs from Koji
2. rpm -Uvh --oldpackage them
3. yum update NetworkManager
4. yum update initscripts
  
Actual results:
#3 does not update anything. #4 fails because of file conflicts with NM.

Expected results:
Should work fine

Additional info:
Comment 1 seth vidal 2010-06-09 14:18:52 EDT
you need to provide A LOT more information here.

Specifically what is the failure that you received from yum?
Comment 2 seth vidal 2010-06-09 14:34:04 EDT
provide:
yum --disablerepo=updates list initscripts NetworkManager\*
Comment 3 James Antill 2010-06-09 14:41:25 EDT
As I said in email, it's not a yum bug if you exclude packages and then can't update them.
Comment 4 Michel Alexandre Salim 2010-06-10 03:49:01 EDT
Apologies -- turns out I did add an exclusion back in March, and had forgotten about it in the meantime.

Note You need to log in before you can comment on or make changes to this bug.