Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602431 - [abrt] crash in sympy-0.6.6-3.fc13: numbers.py:5:<module>:ImportError: No module named libmpf
[abrt] crash in sympy-0.6.6-3.fc13: numbers.py:5:<module>:ImportError: No mod...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sympy (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
abrt_hash:9a7478eb
:
: 600329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 16:14 EDT by Przemek Klosowski
Modified: 2010-09-15 18:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: sympy-0.6.7-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 18:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.16 KB, text/plain)
2010-06-09 16:14 EDT, Przemek Klosowski
no flags Details
sympy patch to be applied in /usr/lib/python2.6/site-packages/sympy (5.30 KB, patch)
2010-06-10 10:36 EDT, Przemek Klosowski
no flags Details | Diff

  None (edit)
Description Przemek Klosowski 2010-06-09 16:14:49 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/isympy
comment: missing libmpf libraries prevent sympy from working
component: sympy
executable: /usr/bin/isympy
kernel: 2.6.33.5-112.fc13.i686.PAE
package: sympy-0.6.6-3.fc13
reason: numbers.py:5:<module>:ImportError: No module named libmpf
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. run isympy
2. observe crash
3.
Comment 1 Przemek Klosowski 2010-06-09 16:14:50 EDT
Created attachment 422689 [details]
File: backtrace
Comment 2 Przemek Klosowski 2010-06-10 10:34:49 EDT
It looks like a version mismatch between sympy and libmp. I am new to both, so I am not sure what is the compatibility matrix (is sympy lagging behind libmp or the other way around). 

I found a way to fix it by patching sympy (see attached diff -c from the sympy lib directory /usr/lib/python2.6/site-packages/sympy

Also, isympy prefers ipython; it is not a hard dependency because it falls back to using plain python interpreter, but perhaps the ipython package should be a dependency of sympy.
Comment 3 Przemek Klosowski 2010-06-10 10:36:03 EDT
Created attachment 422933 [details]
sympy patch to be applied in /usr/lib/python2.6/site-packages/sympy
Comment 4 Przemek Klosowski 2010-06-10 11:36:39 EDT
The patch provided isn't production quality; I removed the include MP_BASE because it doesn't seem to be defined in the provided libmp version, but sympy uses it, for instance when calculating integrate(exp(-x**2), (x, -oo, oo)).
Comment 5 Przemek Klosowski 2010-06-15 13:42:00 EDT
fredrik.johansson commented on the sympy discussion blog
http://code.google.com/p/sympy/issues/detail?id=1954

   This was fixed three months ago (this was the main patch: 
   http://git.sympy.org/?p=sympy.git;a=commit;h=5faaa3ce262f83a4c4e9729c8bb12aa4e3e8c172)

   I suggest updating SymPy in Fedora to 0.6.7?

   As for why the Fedora SymPy doesn't use SymPy's internal copy of mpmath to avoid this problem... I'm dubious about that.

Indeed, it looks like Fedora sympy should be updated
Comment 6 Conrad Meyer 2010-06-15 13:51:44 EDT
Someone already tried to bump Sympy to 0.6.7 but didn't go through and fix the patch to remove the built-in mpmath (e.g. http://koji.fedoraproject.org/koji/buildinfo?buildID=148686 ).

Currently, I don't have the time to fix the patch, and I'm not really interested in SymPy anymore.
Comment 7 José Matos 2010-08-28 04:07:35 EDT
*** Bug 600329 has been marked as a duplicate of this bug. ***
Comment 8 José Matos 2010-08-28 05:42:02 EDT
Rebuilding the srpm from http://koji.fedoraproject.org/koji/buildinfo?buildID=187322

fixes that problem for me on F-13.

I am behind a (stupid) proxy so I can build the package in bodhi but it would be nice if someone could do it.
Comment 9 Susi Lehtola 2010-08-30 16:21:32 EDT
Przemek: please try the scratch build at 
 http://koji.fedoraproject.org/koji/taskinfo?taskID=2435934
to see if it fixes your problem.

direct link to rpm is
http://koji.fedoraproject.org/koji/getfile?taskID=2435936&name=sympy-0.6.7-4.fc12.noarch.rpm
Comment 10 boucher.samuel.c 2010-09-03 14:07:39 EDT
Package: sympy-0.6.6-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.lunch isympy from terminal
2.
3.


Comment
-----
lunch isympy ( also importing sympy in python cause a similar crash)
Comment 11 Owen Taylor 2010-09-06 13:55:36 EDT
The spec file in the Fedora 14 branch for 0.6.7 builds fine against Fedora 13 and seems to work in limited testing.

There is one unexpected test failure when the build runs the test suite out of 1476 tests - don't have the experience to know if it's serious or not, but it's certainly much better than complete non-workingness, which is the current state of Fedora 13!

Does this just need someone to copy the changes to the Fedora 13 branch, build, and file an update request? I can do that if that if there's nobody else paying attention, though I don't want to pick up the package long term.
Comment 12 Susi Lehtola 2010-09-06 14:03:22 EDT
The failed test is just a whitespace test.

I'll file the update now.
Comment 13 Fedora Update System 2010-09-06 14:20:08 EDT
sympy-0.6.7-5.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/sympy-0.6.7-5.fc12
Comment 14 Fedora Update System 2010-09-06 14:20:21 EDT
sympy-0.6.7-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/sympy-0.6.7-5.fc13
Comment 15 Fedora Update System 2010-09-07 22:18:21 EDT
sympy-0.6.7-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sympy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/sympy-0.6.7-5.fc13
Comment 16 Fedora Update System 2010-09-15 18:29:26 EDT
sympy-0.6.7-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-09-15 18:34:56 EDT
sympy-0.6.7-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.