Bug 602468 - RFE: don't block read-only access to package database
Summary: RFE: don't block read-only access to package database
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-09 22:06 UTC by Michael Monreal
Modified: 2014-01-21 23:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 01:40:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Monreal 2010-06-09 22:06:22 UTC
One of the most annoying problems with yum is that it blocks all access to the package database if one yum process is working, even if the second process only needs read access. Example:

- Terminal A: yum update
- Terminal B: yum search foo

Actions like "search" and "info" should always work.

Comment 1 seth vidal 2010-06-10 01:40:34 UTC
the install/update process is running as root

if you run the search/info process as a user it is fine.

if you run it as root the reason it can't work is b/c the cache is in the same location and could be being updated. So we lock that location.

Comment 2 Michael Monreal 2010-06-10 13:44:10 UTC
Thanks for the explanation. I had "yum" aliased to "sudo yum", so everything was running under the same account. Worked around this now and it is already a nice improvement.

However, if a "yum update" is in progress for example, why can't I search the package list with packagekit? Is there a technical reason or is this a packagekit bug?

Comment 3 seth vidal 2010-06-10 13:51:05 UTC
During an update, especially if it is still depsolving, new metadata can be being downloaded. Querying the metadata when other things are writing to it is unlikely to gain results you want.


Note You need to log in before you can comment on or make changes to this bug.