Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 602507 - Incorrectly reports "all software is up to date" when network is down
Incorrectly reports "all software is up to date" when network is down
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 22:17 EDT by Christopher Beland
Modified: 2010-06-10 06:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 06:05:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2010-06-09 22:17:12 EDT
When I ran gpk-update-viewer from the Gnome menu, I got a dialog box that said:

>>
All software is up to date

There are no software updates available for your computer at this time.
<<

This was not precisely true.  Actually, the network was down because I'd just installed the OS and hadn't yet selected a wireless network. gpk-update-viewer should be smart enough to know that the network is down and display a more accurate and helpful message.  I did later get a "Software source download failed" message, but given the assurance of the first message, some users may be misled into thinking their system is safe when they actually need to download and install published security updates.

I experienced this with gnome-packagekit-2.30.1-1.fc13.i686; the same problem occurs with gnome-packagekit-2.30.2-1.fc13.i686 when I intentionally disable the network.
Comment 1 Richard Hughes 2010-06-10 06:05:06 EDT
I've applied this to upstream:

commit 0ad3c9f144e5858f58664feff6432420cffb2380
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jun 10 11:02:39 2010 +0100

    Add a modal error box to the update viewer if there is no network. Fixes rh#602507

:100644 100644 a477f5d... 2b807fa... M  src/gpk-update-viewer.c

I can't backport to F13 as there are new strings which would be a break. Thanks for reporting this bug.

Note You need to log in before you can comment on or make changes to this bug.