Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602557 - Multi-guest created with serial log files fail to write all serial information
Multi-guest created with serial log files fail to write all serial information
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 03:10 EDT by Alex Jia
Modified: 2010-06-17 00:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 00:37:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2010-06-10 03:10:35 EDT
Description of problem:
Staring two guests(or even more) separately with a serial log file,
only first starting guest exists all serial information in serial
log file.  

In addition, outputting serial information to terminal is the same 
error for multi-guest.

Version-Release number of selected component (if applicable):
[root@dhcp-66-70-62 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux release 6.0 Beta (Santiago)

[root@dhcp-66-70-62 ~]# uname -a
Linux dhcp-66-70-62.nay.redhat.com 2.6.32-33.el6.x86_64 #1 SMP Thu Jun 3 13:00:03 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[root@dhcp-66-70-62 ~]# virsh version
Compiled against library: libvir 0.8.1
Using library: libvir 0.8.1
Using API: QEMU 0.8.1
Running hypervisor: QEMU 0.12.1


How reproducible:
always

Steps to Reproduce:
1.define two guests separately with a serial log file
2.start two guests
3.check serial log file
  
Actual results:
There isn't all serial information in the serial log file for the second starting guest.


Expected results:
There is own all serial information in the serial log file for each guest


Additional info:
Xml description for serial and console: 
    <serial type='file'>
      <source path='/tmp/{guestname}-serial.log'/>
      <target port='0'/>
    </serial>
    <console type='file'>
      <source path='/tmp/{guestname}-serial.log'/>
      <target port='0'/>
    </console>
Comment 2 RHEL Product and Program Management 2010-06-10 03:33:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jiri Denemark 2010-06-16 15:06:41 EDT
Hmm, works as expected for me. Could you attach the XML for the two guests that are not working for you?
Comment 4 Alex Jia 2010-06-16 23:19:36 EDT
Hi Jiri,
I renew check second guest, the second guest is missing console argument in the kernel command line, it works also for me, so it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.