Bug 602594 - Myproxy server leaves behind zombie processes
Summary: Myproxy server leaves behind zombie processes
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: myproxy (Show other bugs)
(Show other bugs)
Version: el5
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 09:24 UTC by Andreas Haupt
Modified: 2010-06-30 14:22 UTC (History)
2 users (show)

Fixed In Version: myproxy-5.1-2.el5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 17:16:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/myproxy-server.config (31.30 KB, application/octet-stream)
2010-06-10 09:24 UTC, Andreas Haupt
no flags Details

Description Andreas Haupt 2010-06-10 09:24:36 UTC
Created attachment 422839 [details]
/etc/myproxy-server.config

Description of problem:

The myproxy server leaves behind a zombie process every time a client fetches new credentials via myproxy-logon.

Version-Release number of selected component (if applicable):

myproxy-server-5.1-2.el5.x86_64

How reproducible:

always

Steps to Reproduce:
1. create a myproxy cert with myproxy-init
2. retrieve the myproxy cert with myproxy-logon -> one additional zombies process
  
Actual results:

[susi-vm4] /root # ps auxwww | grep myproxy
myproxy  24949  0.0  0.0 142540   924 ?        S    Jun09   0:00 /usr/sbin/myproxy-server -s /var/lib/myproxy
myproxy  25380  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  25687  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  26259  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  27064  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  27708  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  28352  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  29031  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  29675  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  30318  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  30962  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  31606  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>
myproxy  32249  0.0  0.0      0     0 ?        Z    Jun09   0:00 [myproxy-server] <defunct>

Expected results:

It shouldn't create proxies ...

Additional info:

Comment 1 Andreas Haupt 2010-06-10 09:26:14 UTC
... ahem, I mean, it shouldn't create zombies ;-)

Comment 2 Steve Traylen 2010-06-10 09:32:54 UTC
Does the myproxy-login actually work ?

What about logs both client side and server side?

I also noticed this once and when I went back to look at it went away.

My only guess at the time for what had changed is the server actually had installed the
CA of the myproxy's host certificate in /etc/grid-security/certificates

 I never got around to removing them again to confirm this was indeed the problem.

Steve.

Comment 3 Andreas Haupt 2010-06-10 11:14:35 UTC
Yes, everything works fine except those accumulating zombies.

On the server side:

Jun 10 12:08:17 susi-vm4 myproxy-server[10796]: myproxy-server v5.1 9 Mar 2010 PAM SASL KRB5 LDAP VOMS OCSP starting at Thu Jun 10 12:08:17 2010 
Jun 10 12:08:17 susi-vm4 myproxy-server[10796]: reading configuration file /etc/myproxy-server.config
Jun 10 12:08:17 susi-vm4 myproxy-server[10796]: SASL enabled, policy required
Jun 10 12:08:17 susi-vm4 myproxy-server[10796]: Processing usage_stats_target (usage-stats.cilogon.org:4810) 
Jun 10 12:08:17 susi-vm4 myproxy-server[10796]: USAGE: Initializing (usage-stats.cilogon.org:4810) (VvtrlLB)
Jun 10 12:08:19 susi-vm4 myproxy-server[10796]: Starting myproxy-server on localhost:7512...
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: Connection from 141.34.2.11
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: Authenticated client <anonymous>
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: Received GET request for username ahaupt
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: SASL authentication succeeded for ahaupt
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: Delegating credentials for /O=GermanGrid/OU=DESY/CN=Andreas Haupt lifetime=43200
Jun 10 12:08:31 susi-vm4 myproxy-server[10808]: Client <anonymous> disconnected

The zombie of the process serving the client (10808) is still there afterwards:

[susi-vm4] /root # pp 10808
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
myproxy  10808  0.0  0.0      0     0 ?        Z    12:08   0:00 [myproxy-server] <defunct>

I don't understand what you mean with "had installed the CA of the myproxy's host certificate in /etc/grid-security/certificates". /etc/grid-security/certificates is needed for proper function so what can I change there?

Cheers,
Andreas

Comment 4 Steve Traylen 2010-06-10 19:07:13 UTC
Please ignore completely comment #3 I did have a problem with not having CAs installed.

I see also the zombies.

# pgrep -fl myproxy
25167 /usr/sbin/myproxy-server -s /var/lib/myproxy -v

$ grid-proxy-init
$ /usr/sbin/myproxy-test
...
MyProxy Tests Complete: 46 tests passed, 0 tests failed

myproxy  25167  0.0  0.0 336460   976 ?        S    21:02   0:00 /usr/sbin/myproxy-server -s /var/lib/myproxy -v
myproxy  25248  0.1  0.0      0     0 ?        Z    21:02   0:00 [myproxy-server] <defunct>
myproxy  25254  0.0  0.0      0     0 ?        Z    21:02   0:00 [myproxy-server] <defunct>
myproxy  25259  0.0  0.0      0     0 ?        Z    21:02   0:00 [myproxy-server] <defunct>
myproxy  25279  0.0  0.0      0     0 ?        Z    21:02   0:00 [myproxy-server] <defunct>
myproxy  25296  0.0  0.0      0     0 ?        Z    21:02   0:00 [myproxy-server] <defunct>
...
myproxy  25429  0.0  0.0      0     0 ?        Z    21:03   0:00 [myproxy-server] <defunct>

in fact 90 zombies in total.

Hmmm,

Comment 5 Jim Basney 2010-06-10 20:56:49 UTC
It appears the issue is specific to globus pthr flavor builds of the myproxy-server. For some reason building the myproxy-server with a pthr flavor disables the sigchld handling. Note myproxy is not multi-threaded and is recommended to be built with a non-pthr globus flavor. (The myproxy-server is multi-process, not multi-thread.) Given the need to build myproxy RPMs with pthr flavors, I certainly see this as something we need to diagnose and fix, and I opened an upstream bug:

  http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=7048

Comment 6 Jim Basney 2010-06-10 22:48:18 UTC
Patch committed upstream:
http://lists.globus.org/pipermail/myproxy-commit/2010-June/000429.html

The fix will appear in MyProxy v5.2.

Comment 7 Fedora Update System 2010-06-12 23:13:20 UTC
myproxy-5.1-2.el5.1 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el5.1

Comment 8 Fedora Update System 2010-06-12 23:13:31 UTC
myproxy-5.1-1.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc11.1

Comment 9 Fedora Update System 2010-06-12 23:13:39 UTC
myproxy-5.1-1.fc12.1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc12.1

Comment 10 Fedora Update System 2010-06-12 23:13:49 UTC
myproxy-5.1-2.el4.1 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el4.1

Comment 11 Fedora Update System 2010-06-12 23:13:57 UTC
myproxy-5.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/myproxy-5.1-3.fc13

Comment 12 Andreas Haupt 2010-06-14 06:52:48 UTC
Good news! myproxy-5.1-2.el5.1 solves the problem for RHEL5. I haven't tested the other distributions, though.

Cheers & thanks,
Andreas

Comment 13 Steve Traylen 2010-06-14 07:00:48 UTC
Andreas, 
 If you can provide karma, it's good for the process.

 https://admin.fedoraproject.org/updates/myproxy-5.1-2.el5.1

 especially if you login to the that page and provide karma then the karma
 counts. three good karma's and the package is released, otherwise you need
 to wait a couple of weeks.

Comment 14 Fedora Update System 2010-06-14 17:13:14 UTC
myproxy-5.1-1.fc12.1 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc12.1

Comment 15 Fedora Update System 2010-06-14 17:13:50 UTC
myproxy-5.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-3.fc13

Comment 16 Fedora Update System 2010-06-14 17:27:13 UTC
myproxy-5.1-1.fc11.1 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc11.1

Comment 17 Fedora Update System 2010-06-14 21:53:40 UTC
myproxy-5.1-2.el5.1 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-2.el5.1

Comment 18 Fedora Update System 2010-06-14 21:54:23 UTC
myproxy-5.1-2.el4.1 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-2.el4.1

Comment 19 Fedora Update System 2010-06-28 17:15:57 UTC
myproxy-5.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2010-06-28 17:19:00 UTC
myproxy-5.1-1.fc12.1 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2010-06-30 14:21:26 UTC
myproxy-5.1-2.el4.1 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2010-06-30 14:22:28 UTC
myproxy-5.1-2.el5.1 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.