Bug 6026 - libpng-devel install fails on dependency typo
libpng-devel install fails on dependency typo
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: libpng (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-17 19:38 EDT by tawood
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-19 10:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tawood 1999-10-17 19:38:00 EDT
# rpm -Uvh libpng-1.0.3-4.i386.rpm
libpng
##################################################
# rpm -ivh libpng-devel-1.0.3-4.i386.rpm
error: failed dependencies:
        libpng = 1:1.0.3 is needed by libpng-devel-1.0.3-4

The dependency failure above appears to be a typo in the
SPEC for libpng-devel.

Work around, of course, --nodeps.
Comment 1 Bill Nottingham 1999-10-18 09:28:59 EDT
Are you using the RPM that shipped with RHL6.1?  You need it
to understand that dependency format.
Comment 2 tawood 1999-10-18 12:34:59 EDT
Yes...
# rpm -q rpm
rpm-3.0.3-2
Comment 3 Jeff Johnson 1999-10-19 15:46:59 EDT
I can't reproduce this problem on i386 using the 6.1 packages
	rpm-3.0.3-2
	libpng-1.0.3-4
	libpng-devel-1.0.3-4
However, you are probably using a libpng.spec that didn't have
	%package devel
	...
	Requires: libpng = 1:1.0.3-4
You might also want to double check the rpm version -- there were
changes in handling versioned dependencies in the 2 weeks before 6.1
was frozen that exhibited the behavior that you are describing.

BTW, it's not a typo -- the libpng package has an epoch (i.e. the
leading 1:) that's part of the dependency. This is new in rpm-3.0.3.
Comment 4 tawood 1999-10-19 16:03:59 EDT
I will take your word that it is fixed... here is the rpm version I
have installed... downloaded from a mirror site 2 days ago.

If this opens the bug.. you can resolve it again.. just FYI

ftp://gatekeeper.dec.com/pub/linux/redhat/redhat-6.1/i386/RedHat/RPMS/rpm-3.0.3-2.i386.rpm

[root@C386420-A gd]# rpm -qi rpm
Name        : rpm                          Relocations: (not
relocateable)
Version     : 3.0.3                             Vendor: Red Hat
Software
Release     : 2                             Build Date: Sat 25 Sep
1999 08:49:11 PM EDT
Install date: Fri 15 Oct 1999 06:40:20 PM EDT      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM:
rpm-3.0.3-2.src.rpm
Size        : 2914363                          License: GPL
Packager    : Red Hat Software <http://developer.redhat.com/bugzilla>
Summary     : The Red Hat package management system.
Description :
The Red Hat Package Manager (RPM) is a powerful command line driven
package management system capable of installing, uninstalling,
verifying, querying, and updating software packages.  Each software
package consists of an archive of files along with information about
the package like its version, a description, etc.
Comment 5 Michael K. Johnson 1999-11-19 10:26:59 EST
re-resolving...
Comment 6 Pekka Savola 2000-04-15 06:29:59 EDT
The typo strikes back :)

----
rpm -Uvh /usr/src/redhat/RPMS/i386/libpng-devel-1.0.6-1.i386.rpm
error: failed dependencies:
        libpng = 2:1.0.6 is needed by libpng-devel-1.0.6-1
----
This should probably be 1:1.0.6.

Note You need to log in before you can comment on or make changes to this bug.