Bug 602609 - GUI rhn_register - DeprecationWarning: use set_markup() instead self.dialog.label.set_line_wrap(False)
Summary: GUI rhn_register - DeprecationWarning: use set_markup() instead self.dialog.l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Milan Zázrivec
QA Contact: Martin Minar
URL:
Whiteboard:
: 604719 (view as bug list)
Depends On:
Blocks: 582655 559492
TreeView+ depends on / blocked
 
Reported: 2010-06-10 09:57 UTC by Jiri Kastner
Modified: 2016-07-04 00:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:04:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0565 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and ehnancement update 2011-05-18 17:57:10 UTC

Description Jiri Kastner 2010-06-10 09:57:01 UTC
Description of problem:
when registering to spacewalk/satellite without base channels for rhel6, you message window with error class code 70: "all available subscriptions for the requested channel have been exhausted. please contact...." and as bonus i got deprecationwarning

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-20.el6.noarch
rhn-setup-gnome-1.0.0-20.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. prepare satellite/spacewalk with no channels
2. register rhel5 - no subscriptions, no depricationwarning
3. register rhel6 - no subscriptions, depricationwarning
  
Actual results:
/usr/share/rhn/up2date_client/messageWindow.py:72: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_line_wrap(False)
/usr/share/rhn/up2date_client/messageWindow.py:73: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_use_markup(True)

Expected results:
no warnings

Additional info:

Comment 1 Jan Pazdziora 2010-06-15 06:37:05 UTC
I talked to the pygtk2 maintainer about this in bug 596076.

Comment 3 Milan Zázrivec 2010-06-16 19:30:55 UTC
*** Bug 604719 has been marked as a duplicate of this bug. ***

Comment 5 Šimon Lukašík 2010-07-30 11:09:04 UTC
Note: This same issue occurs also when registering with firstboot-1.110.6-1.el6.

Comment 6 Igor Bezrodnik 2010-12-08 08:22:32 UTC
rhn_register
/usr/share/rhn/up2date_client/messageWindow.py:72: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_line_wrap(False)
/usr/share/rhn/up2date_client/messageWindow.py:73: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_use_markup(True)

Comment 7 Igor Bezrodnik 2010-12-14 19:34:18 UTC
Problem registering system:

Error Class Code: 70
Error Class Info: 
     All available subscriptions for the requested channel have been exhausted.
     Please contact a Red Hat Network Sales associate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

[root@# rhn_register
/usr/share/rhn/up2date_client/messageWindow.py:72: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_line_wrap(False)
/usr/share/rhn/up2date_client/messageWindow.py:73: DeprecationWarning: use set_markup() instead
  self.dialog.label.set_use_markup(True)

Comment 8 Milan Zázrivec 2011-01-19 17:56:16 UTC
spacewalk.git master: d15c755d84072c980cc6e68ab023eeb890f5a665
satellite.git CLIENT-RHEL-6: f5795d267993b4c015847e0ba02f313f4a96085d

Comment 10 Martin Minar 2011-02-22 15:10:41 UTC
Verified in rhn-setup-1.0.0-48.el6.noarch

Comment 11 errata-xmlrpc 2011-05-19 13:04:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0565.html


Note You need to log in before you can comment on or make changes to this bug.