Bug 602611 - rhn_register - Freeing read locks for locker 0x... messages
rhn_register - Freeing read locks for locker 0x... messages
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 582655 559492
  Show dependency treegraph
 
Reported: 2010-06-10 06:02 EDT by Jiri Kastner
Modified: 2010-11-23 08:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 07:21:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-06-10 06:02:45 EDT
Description of problem:
noticed warnings regarding freeing read locks

Version-Release number of selected component (if applicable):
rhn-setup-gnome-1.0.0-20.el6.noarch
rhn-setup-1.0.0-20.el6.noarch


How reproducible:
sometime, during package profile gathering, sending

Steps to Reproduce:
1. rhn_register
2. warning messages
  
Actual results:
[root@ibm-z10-09 rhn]# rhn_register 
Freeing read locks for locker 0x15: 1816/2199028151216
Freeing read locks for locker 0x17: 1816/2199028151216
Freeing read locks for locker 0x18: 1816/2199028151216


Expected results:
no warnings

Additional info:
Comment 1 Jiri Kastner 2010-06-11 02:39:31 EDT
registered on s390x, x86_64
Comment 2 Milan Zázrivec 2010-06-17 12:12:39 EDT
I'm pretty sure those messages come from db4, though I cannot really
reproduce it.

Panu, do you have any idea what scenario might cause this error to
be propagated from db4 into rpm / rpm-python?
Comment 3 Panu Matilainen 2010-06-18 04:53:58 EDT
That's just db4's way of saying "previous user of rpmdb made a mess and left stale locks behind, hold your nose while I clean it up".

The message itself is not at all an error, but it does indicate a problem somewhere: some program using rpmdb either crashed or got forcibly killed, or is not freeing up rpmdb-related resources after use.
Comment 4 Clifford Perry 2010-07-06 15:55:45 EDT
minor - punting to rhel 6.1, blockers/exceptions only now. 

Milan close not a bug if needed (which I think we may) - or look at ways to sanely capture and report/log the messages. 

Cliff
Comment 6 Milan Zázrivec 2010-11-23 07:21:05 EST
Based on comment #3, I'm closing this with WONTFIX -- there's no way
for us to fix this warning in rhn-client-tools.
Comment 7 Panu Matilainen 2010-11-23 08:04:14 EST
Well, if such warnings are regularly seen as part of normal operation, there's a bug somewhere that needs fixing - normal operation must not either forcibly kill rpm-related processes or exit without cleaning up, causing warnings. Whether they're caused by something in rhn-client-tools or somewhere else should be investigated.

Note You need to log in before you can comment on or make changes to this bug.