This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 602615 - [abrt] crash in gthumb-2.11.3-1.fc13: raise: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
[abrt] crash in gthumb-2.11.3-1.fc13: raise: Process /usr/bin/gthumb was kill...
Status: CLOSED DUPLICATE of bug 588039
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
abrt_hash:320dc0a088f7459cc2f9a5bc54f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 06:15 EDT by not_edi
Modified: 2010-07-16 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 19:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (8.89 KB, text/plain)
2010-06-10 06:15 EDT, not_edi
no flags Details

  None (edit)
Description not_edi 2010-06-10 06:15:04 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gthumb
component: gthumb
crash_function: raise
executable: /usr/bin/gthumb
global_uuid: 320dc0a088f7459cc2f9a5bc54f85d20490fd19b
kernel: 2.6.33.5-112.fc13.x86_64
package: gthumb-2.11.3-1.fc13
rating: 4
reason: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.Xorg cannot load glx Module because there is a lib /lib64/libaudit.so.0.0.0 needed to load the module
but only /lib64/libaudit.so.1.0.0 is available
2.
My secound attemped was to install such a lib from an older fedora this fails because 
 [   146.248] (II) LoadModule: "glx"
 75 [   146.248] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
 76 [   146.299] (II) Module glx: vendor="X.Org Foundation"
 77 [   146.299]    compiled for 1.6.1.901, module version = 1.0.0
 78 [   146.299]    ABI class: X.Org Server Extension, version 2.0
 79 [   146.299] (EE) module ABI major version (2) doesn't match the server's ve    rsion (3)
 80 [   146.299] (II) UnloadModule: "glx"
 81 [   146.299] (II) Unloading /usr/lib64/xorg/modules/extensions/libglx.so
 82 [   146.299] (EE) Failed to load module "glx" (module requirement mismatch,     0)

3.I did a preupgrade from fedora 11 to 13 maybe this caused the trouble.
Comment 1 not_edi 2010-06-10 06:15:07 EDT
Created attachment 422846 [details]
File: backtrace
Comment 2 not_edi 2010-06-10 06:15:35 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Xorg cannot load glx Module because there is a lib /lib64/libaudit.so.0.0.0 needed to load the module
but only /lib64/libaudit.so.1.0.0 is available
2.
My secound attemped was to install such a lib from an older fedora this fails because 
 [   146.248] (II) LoadModule: "glx"
 75 [   146.248] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
 76 [   146.299] (II) Module glx: vendor="X.Org Foundation"
 77 [   146.299]    compiled for 1.6.1.901, module version = 1.0.0
 78 [   146.299]    ABI class: X.Org Server Extension, version 2.0
 79 [   146.299] (EE) module ABI major version (2) doesn't match the server's ve    rsion (3)
 80 [   146.299] (II) UnloadModule: "glx"
 81 [   146.299] (II) Unloading /usr/lib64/xorg/modules/extensions/libglx.so
 82 [   146.299] (EE) Failed to load module "glx" (module requirement mismatch,     0)

3.I did a preupgrade from fedora 11 to 13 maybe this caused the trouble.
Comment 3 Michel Alexandre Salim 2010-07-16 19:41:56 EDT
Even without glx, gthumb really should not have failed. This is a problem in early 2.11.x versions that absolutely depends on clutter (and glx) for its slideshow functionality. 2.11.4 and above have a fallback when this is not available.

You probably still want to fix the library problem you noticed, though.

*** This bug has been marked as a duplicate of bug 588039 ***

Note You need to log in before you can comment on or make changes to this bug.