Bug 60262 - gcc3-3.0.1-3 doesnt compile perl 5.6.1 from source
Summary: gcc3-3.0.1-3 doesnt compile perl 5.6.1 from source
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-23 07:12 UTC by Mithun Bhattacharya
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:26:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mithun Bhattacharya 2002-02-23 07:12:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
make test fails with reason "ELF file's phentsize not the expected"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download latest stable version of perl from http://www.cpan.org/src/stable.tar.gz
2. tar xzf stable.tar.gz
3. cd perl-5.6.1/
4. rm -f config.sh Policy.sh
5. sh Configure -de
6. make
7. make test
	

Actual Results:  A small subset of the error messages is as follows. Basically
it fails 52 of the 205 tests.
--------------------
lib/syslfs...........Can't load '../lib/auto/Fcntl/Fcntl.o' for module Fcntl:
../lib/auto/Fcntl/Fcntl.o: ELF file's phentsize not the expected size at
../lib/XSLoader.pm line 75.
 at ../lib/Fcntl.pm line 220
Compilation failed in require at lib/syslfs.t line 14.
BEGIN failed--compilation aborted at lib/syslfs.t line 15.
FAILED at test 0
lib/syslog...........Can't load '../lib/auto/Socket/Socket.o' for module Socket:
../lib/auto/Socket/Socket.o: ELF file's phentsize not the expected size at
../lib/XSLoader.pm line 75.

Expected Results:  It should say all tests successful.

Additional info:

This server was a very toned down server. I had opted for a custom installation
and had deselected Developement packages and Utilites and after that selected
gcc3 which in turn had pulled in a couple more packages including glibc-devel. I
do know that these were the packages which definitely were installed.
gcc3-3.0.1-3
gcc3-c++-3.0.1-3
libstdc++3-3.0.1-3
libstdc++3-devel-3.0.1-3

I believe libstdc++-2.96 was also installed.

I removed gcc3, gcc3-c++, libstdc++3 and libstdc++3-devel and ran up2date gcc
gcc-c++ and re ran the compillation procedure for perl and it worked perfectly.

Comment 1 Jakub Jelinek 2002-03-04 15:53:15 UTC
Unless you tweaked perl manually, it wouldn't use gcc3 because it is available
only as gcc3 (resp. g++3 etc.) commands.

Comment 2 Mithun Bhattacharya 2002-03-05 11:01:43 UTC
All perl needs is something which can compile C code preferably with the "cc"
command so I made a symlink from /usr/bin/gcc3 to /usr/bin/cc . Please note
compilation went through completely without aborting at any stage.


Note You need to log in before you can comment on or make changes to this bug.