Bug 602630 - Schedd crashes after submitting job over QMF
Schedd crashes after submitting job over QMF
Status: CLOSED DUPLICATE of bug 602637
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-qmf (Show other bugs)
Development
All Linux
high Severity high
: 1.3
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 07:08 EDT by Martin Kudlej
Modified: 2011-03-17 14:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 09:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2010-06-10 07:08:45 EDT
Description of problem:
Scheduler crashes after submitting job over QMF.

Version-Release number of selected component (if applicable):
condor-7.4.3-0.17.el5
condor-qmf-7.4.3-0.17.el5

How reproducible:
100%

Steps to Reproduce:
1. set up codnor qmf
2. submit job over qmf
3. watch crash in scheduler log file
  
Actual results:
Scheduler crashes.

Expected results:
Scheduler will not crash.

Additional info:
Schedd log:
06/10 05:52:46 (pid:18589) ERROR "Assertion ERROR on (!active_transaction)" at line 364 in file classad_log.cpp
Stack dump for process 18589 at timestamp 1276163566 (12 frames)
condor_schedd(dprintf_dump_stack+0x44)[0x817d344]
condor_schedd[0x817f0a4]
[0x740420]
condor_schedd(_EXCEPT_+0x93)[0x817d213]
condor_schedd(_ZN10ClassAdLog16BeginTransactionEv+0x41)[0x81caf21]
condor_schedd(_Z16BeginTransactionv+0x11)[0x8114411]
condor_schedd(_ZN9Scheduler10sendAlivesEv+0x1e)[0x80f86be]
condor_schedd(_ZN12TimerManager7TimeoutEv+0x14b)[0x817c8ab]
condor_schedd(_ZN10DaemonCore6DriverEv+0x244)[0x8163a84]
condor_schedd(main+0xd80)[0x8177290]
/lib/libc.so.6(__libc_start_main+0xdc)[0xb9de9c]
condor_schedd[0x80e4601]

Submit example:
from sys import exit
from qmf.console import Session

UNIVERSE = {"VANILLA": 5, "SCHEDULER": 7, "GRID": 9, "JAVA": 10, "PARALLEL": 11, "LOCAL": 12, "VM": 13}

__annotations__ = {"Requirements": "com.redhat.mrg.grid.Expression"}
ad = {"Cmd":          "/bin/sleep",
      "Args":         "120",
      "Requirements": "TRUE",
      "JobUniverse":  UNIVERSE["VANILLA"],
      "Iwd":          "/tmp",
      "Owner":        "nobody",
      "!!descriptors": __annotations__
}

session = Session();
session.addBroker()
schedulers = session.getObjects(_class="scheduler", _package="com.redhat.grid")
result = schedulers[0].SubmitJob(ad)
Comment 1 Matthew Farrellee 2010-06-10 09:54:33 EDT

*** This bug has been marked as a duplicate of bug 602637 ***

Note You need to log in before you can comment on or make changes to this bug.