Bug 60269 - srpm's configure needs patch for libxml2 locations
Summary: srpm's configure needs patch for libxml2 locations
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-23 16:19 UTC by James Manning
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-23 16:19:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Manning 2002-02-23 16:19:36 UTC
Pretty simple - libxml2 sticks include files in /usr/include/libxml2/libxml/* 
including the important one that php's configure looks for, tree.h.  php's 
configure is looking for it as include/libxml/tree.h, though, so it doesn't 
find it in /usr.  One fix would be to have libxml2 do a symlink in /usr/include 
for libxml -> libxml2/libxml, but since that would probably cause problems in 
support libxml 1.x and 2.x on the same box, the better fix in this case may be 
to have php's configure.

Should be an easyish fix around line 27 or so of php-4.0.6/ext/domxml/config.m4

Comment 1 Phil Copeland 2002-03-04 19:16:59 UTC
There'll be a 4.1.2 errata at some nearish point in the future for 7.2
Have a look in rawhide tonight (03:00est actually) for the 4.1.2 candidate I've
made (the way the build system here works, that'lll be when it'll get pushed
out)

Phil
=--=

Comment 2 Phil Copeland 2002-03-05 19:00:43 UTC
Make that a date for tomorrow 8(
the build system didn't push out the rpms to rawhide like I expected it to

sorry

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.