Bug 60273 - Brother HL-1650 printer will not eject last page in duplex mode
Brother HL-1650 printer will not eject last page in duplex mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-23 14:38 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 15:00:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-23 14:38:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011116

Description of problem:
If I enable duplex printing with the Brother HL-1650 printer, the printer will
not eject the last page if there are an odd number of pages.  For example, if I
print a three page document, pages 1 and 2 will be on the first sheet of paper,
and page 3 will not print.  If I print another document immediately afterwards,
page 3 of the first document and page 1 of the next document will print on the
next sheet of paper.

I've tried enabling 'Send FF' under the 'Driver Options' tab, but it does not
fix the problem.  If I try to print with 'Send EOT' enabled,  I get a couple of
lines of letters and numbers, then the printer starts spitting out blank pages.

I've resorted to printing only one document at a time.  I've created a one page
PostScript document that consists of a couple of spaces.  If the last page does
not print, I print my blank document to force out the last page.

I'm not sure if there should be another option to force a blank page on jobs
with an odd number of pages, or if the 'Send FF' or 'Send EOT' options are broken.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Run 'printconf-gui' and set up a local printer using the
Brother/HL-1650/Postscript driver.
2.  Edit the new queue.
3.  Under the 'Driver Options' tab, set 'Double-Sided Printing' to 'Long Edge
(Standard)', and click 'OK'
4.  Click 'Apply' to use the new settings.
5.  Print a document with an odd number of pages (1, 3, 5, etc).
	

Actual Results:  I get all pages, except for the last page.  For example, if I
print a 5 page document, I get pages 1 through 4 on two sheets of paper, but I
do not get page 5.

Expected Results:  I should get a third sheet of paper with only page 5 on it.

Additional info:

I've tried this with PostScript and PDF documents, and I've had the same problem
with both document types.  I'm not sure about other document types.  As
mentioned above, I've tried setting the 'Send FF' and 'Send EOT' options without
success.
Comment 1 Tim Waugh 2002-02-25 03:21:34 EST
Sounds like 'send EOT' is broken.
Comment 2 Tim Waugh 2002-03-06 09:00:32 EST
Do you get the desired behaviour when printing to that (type of) printer from
any other system?
Comment 3 Need Real Name 2002-03-06 13:09:00 EST
My system is dual boot Windows 98 and RH 7.2.  If I print from Win98, it ejects
the last page every time.  I don't know how the printer behaves with other
versions of Linux, since I do not have room to install anything else on my
laptop, and that is my only computer.

If there is a newer version of the printer software available, I could install
it and give it a try.  I'm not exactly sure which packages I would need to
upgrade though.  If there is a patch that might fix the problem, I'm willing to
try it.
Comment 4 Tim Waugh 2002-03-06 13:15:44 EST
Okay, I was hoping that it was a printer firmware problem. :-)  It clearly isn't.

We are just sending PostScript straight to the printer.  Does Windows tell you
anything useful about any encapsulation that it might be using?  PJL for instance?
Comment 5 Need Real Name 2002-03-06 13:25:37 EST
I can check the Windows settings this evening.

You mentioned earlier that 'Send EOT' may be broken, since it causes the printer
to spew garbage.  Is EOT a standard signal that this printer should know about,
or does each printer use its own mechanism to signal the end of a print job?
Comment 6 Tim Waugh 2002-03-06 13:29:44 EST
There is a large variety of ways of doing it. :-(
Comment 7 Need Real Name 2002-03-18 20:31:37 EST
I checked the Windows driver settings, but I didn't find any useful information :(

I looked on Brother's web site to see if they had any useful information.  I
came across this site:

  http://solutions.brother.com/Library/sol/printer/linux_install.html

They mention some steps to take if the printer driver is not listed.  I tried
each of them (Using HP LaserJet 2, HP LaserJet 4, and Apple LaserWriter), but
none of these printer drivers worked correctly.

The page also states that "Brother are actively working with members of the
Linux community to develop Brother specific device drivers for the Linux
operating system."  I could send them email asking if they have a fix for this
problem.
Comment 8 Need Real Name 2002-04-05 15:00:02 EST
I updated printconf to version 0.3.61 just after my last update, and it seems to
work fine now.  I turned of "Send EOT" and "Send FF", and it now ejects the last
page, even if it only prints on one side.

Note You need to log in before you can comment on or make changes to this bug.